PDF XChange Lite V6 error when printing after upgrade  SOLVED

This Forum is for the use of End Users requiring help and assistance for Tracker Software's PDF-XChange Printer Drivers only - Please do not post requests for older versions of PDF-XChange or the PDF-Tools/OFFice2PDF applications here

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan

Post Reply
chris taylor
User
Posts: 3
Joined: Sun Mar 01, 2015 12:07 am

PDF XChange Lite V6 error when printing after upgrade

Post by chris taylor » Wed Apr 06, 2016 10:53 pm

On Windows 10, just upgraded to PDF Tools V6 which included upgraded Printer Driver V6. I noted after install the old version of the software was there, so uninstalled it.

Every time I try to print I get message - Windows can't print due to a problem with the printer setup.

Driver properties says config and data file are pxcdrv5L.dll. Port is PXC5L and Description is PDF-XChange 2012 Printer Port.

Suggestions to resurrect my printer driver?

User avatar
Patrick-Tracker Supp
Site Admin
Posts: 1668
Joined: Thu Mar 27, 2014 6:14 pm
Location: Vancouver Island
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Patrick-Tracker Supp » Thu Apr 07, 2016 12:10 am

Hello Chris,

Thanks for the post. This may be caused by a pre-existing instance of PDF-XChange Lite 2012. There is currently a conflict that requires the old version to be uninstalled prior to installing Lite V6.

You will now need to go to your Control Panel, right click on any/all instances of lite, and go to "Remove Device". Once that is completed, restart your computer and reinstall using you the installer provided with your license key.

I hope this helps!
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Cheers,

Patrick Charest
Tracker Support North America

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Fri Apr 08, 2016 9:54 am

I have the same problem, also having Windows 10. Indeed, PDF-XChange Lite 2012 was installed before. Now I uninstalled earlier versions several times, re-installed V6, but still the error message remains. Any ideas?

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13548
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Tracker Supp-Stefan » Fri Apr 08, 2016 9:58 am

Hello cokolade,

Welcome to our forums. Can you please check if this will help:
https://www.tracker-software.com/knowledgebase/500

Regards,
Stefan

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Fri Apr 08, 2016 10:49 am

Hello Stefan,
Thank you, I tried this, also with restarting, but the situation is unchanged.

Willy Van Nuffel
User
Posts: 1387
Joined: Wed Jan 18, 2006 12:10 pm

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Willy Van Nuffel » Fri Apr 08, 2016 1:34 pm

Hi,

I do not experience this problem on my own Windows 10 32-bit computer, but maybe the following advise might help.

1) If "PDF-XChange Lite V6 (Home)" is actually still installed but not working correctly, then execute an "Uninstall" of it, via Control Panel > Programs and Features (do NOT uninstall by "Remove device" via "Devices and Printers").
In that manner you should be assured that everything from the new PDF printer is uninstalled correctly.

Restart your computer.

2) Reinstall your previous PDF printer. I suppose that was the old version "PDF-XChange Printer 2012 Lite".
Check if you can print to PDF with it, via a File > Print to that printer.
If that works, then "Uninstall" this printer again via Control Panel > Programs and Features.
In that manner you should be assured that everything from the old PDF printer is uninstalled correctly.

Restart your computer.

3) Given the fact that PDF-XChange Lite V6 depends of a correctly installed and working "Microsoft XPS Document Writer" printer, first check if you can create a XPS-file via a File > Print to that XPS printer.

4) If that works, then finally re-Install your "PDF-XChange Lite V6 (Home)" printer.
PDF-XChange Lite Free (V6) can be downloaded separately.
http://www.tracker-software.com/product ... hange-lite

I hope this will help.

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13548
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Tracker Supp-Stefan » Fri Apr 08, 2016 3:47 pm

Thanks for the help Willy,

cokolade, Chris, - we would love to hear if you managed to resolve your issues!?

Regards,
Stefan

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Fri Apr 08, 2016 3:59 pm

Hi Willy,
Thank you very much for your suggestions. I tried it:
1) Uninstall PDF XChange Editor (6.0.317.0) and restarted.
2) Installed from file PDFX5SA_LE_H the PDF XChange Editor + PDF XChange Lite 2012 (5.5.315.0). Now the Printer "PDF XChange Printer Lite 2012" appears in the printer list. However, if I try to print the error now appears as with V6. Then I uninstalled XChange Printer and Editor.
3) I also tried the printer "Microsoft XPS Document Writer". This works fine.
4) I downloaded and installed PDF XChange Lite V6 Home (6.0.317.0) and afterwards "PDF XChange Lite v6" appears in the printer list. However, printing fails as before. I tested again the XPS Document Writer which still works.

Are there any new ideas? Thank you again.

Willy Van Nuffel
User
Posts: 1387
Joined: Wed Jan 18, 2006 12:10 pm

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Willy Van Nuffel » Fri Apr 08, 2016 6:03 pm

I do not know how far you are prepared to go, and how much time you can spend to it, because resolving this does not seem to be an easy thing. And I regret, myself, I can only talk for Windows 10 32-bit.

At first I would uninstall everything about PDF-XChange software (via Control Panel > Programs and Features).

Then I should verify via Windows File Explorer, if the folder "Tracker Software" has disappeared from C:\Program files
If it is still there, then delete it.

Now in Windows Registry:
- check below HKEY_CURRENT_USER\Software. If you still see a branch "Tracker Software", then delete that branch
- check below HKEY_LOCAL_MACHINE\Software. If you still see a branch "Tracker Software, then delete that branch
- check below HKEY_USERS\.DEFAULT\Printers. Search for keys about "Tracker Software, and if you find some, delete them
- check below HKEY_USERS\.DEFAULT\Software. If you still see a branch "Tracker Software", then delete that (whole) branch
- continue like this by opening the other branches below HKEY_USERS\ and looking for Printers and Software where you see Tracker Software and each time you find it, delete it.

Once this has been done, try by re-installing your PDF-XChange V6 software.

Best regards.

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Sun Apr 10, 2016 3:48 pm

Hello Willy,
Thank you very much again. I followed your proposal:
1. Uninstalled all PDF XChange software via Control Panel
2. Deleted the folder "tracker software" which still was under Program files
3. Checked the registry and deleted the tracker software branches under
- HKEY_CURRENT_USERS\Software
- HKEX_LOCAL_MACHINE\Software
- HKEY_USERS\.DEFAULT\Software
Under HKEY_USERS\.DEFAULT\Printers and and other branches I did not find branches "tracker software"

I restarted the computer and re-installed V6 software 6.0.317.0 from file PDFXVE6.zip. I restarted the computer again and tried to print. Unfortunately, there is still the same error message.

By the way: The exact error message is (in German): "Der E/A-Vorgang wurde wegen eines Threadendes oder einer Anwendungsanforderung abgebrochen", so something like "The I/O process was cancelled due to the end of a thread or a request by an application".

Over the next 4 weeks I am travelling a lot so my reaction time will be longer. Anyhow, I would be grateful for all ideas. Thank you very much and best regards

Willy Van Nuffel
User
Posts: 1387
Joined: Wed Jan 18, 2006 12:10 pm

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Willy Van Nuffel » Sun Apr 10, 2016 4:32 pm

Thanks for your answer cokolade.

In HKEY_USERS, there is also a branch S-1-5-21... with a large number of numeric digits.
Below this, you should normally find a sub-branch Printers, with DevModePerUser, DevModes2 and Settings.
- delete the "keys" concerning PDF-XChange printers in these three sub-sub-branches
In HKEY_USERS, you should also find a sub-branch Software, with Tracker Software
- delete the whole branch

If you should already have deleted the above items, and it still does not work, then I am out of ideas.

Maybe it would be good idea to do a temporal switch from German to English and then note the error message that you get.
You can publish that error message here.

Tracker Support will be our last hope ...

Best regards.

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Thu Apr 21, 2016 10:25 am

Hello Willy,
Thank you again. I repeated the actions of 10 April and additionally searched the registry according to your latest post. I did not find additional branches "Tracker Software" in the registry. As next step I searched the registry for Tracker Software and found some more entries e. g. in HKEY_USERS/.DEFAULT/Software/Mozilla Plugins which I deleted.

Afterwards, the error remined unchanged.

Now, I installed English as system language, so that I can post the original error message:
"The I&O operation has been aborted because of either a thread exit or an application request."

I am quite close to giving up and install PDF24.

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13548
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Tracker Supp-Stefan » Thu Apr 21, 2016 10:37 am

Hello cokolade,

Earlier this week we released build 317.1 of our products. Can you please try installing that and check whether there are still any issues?
Also - try installing the Lite for home version, and the other one (that normally requires a license) - to check if there is an issue with one installer that is not present in the other, and try printing through Lite. If it prints (despite the "DEMO" stamps) - then it will seem the issue is in the installation file for the free for home use package.

Regards,
Stefan

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Thu Apr 21, 2016 3:22 pm

Hello Stefan,
Thank you for the recommendations. I uninstalled everything again, then downloaded and installed the new version 317.1 of PDFXChange Editor from the Tracker website. The editor works well and I can open pdf files. For the printer the error message pops upagain.

Any ideas? As mentioned I will still be travelling a lot the next weeks so possibly there will be longer reaction times.
Kind regards

User avatar
Will - Tracker Supp
Site Admin
Posts: 6806
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Will - Tracker Supp » Thu Apr 21, 2016 3:43 pm

Hi cokolade,

I was under the impression that we had provided a workaround for the issue in the latest release, but I may have been mistaken. For now, please see this KB article:
http://www.tracker-software.com/knowled ... ot-working

Thanks,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Thu Apr 21, 2016 5:50 pm

Hi wiil,
Thank you for the new ideas. I downloaded, ran the .bat file and restarted, but the error persists. What I also checked:
1. The Microsoft XPS Writer works, test page could be produced
2. After running .bat I can find the file XPSSVCS.DLL (which is handled by the .bat file) in these system folders only:
C:\Windows\SysWOW64\spool\drivers\w32x86\PCC\ntprint.inf_fceaf475.cab
C:\Program Files\Tracker Software\PDF-XChange Lite 6\Drivers\x64
C:\Program Files\Tracker Software\PDF-XChange Lite 6\Drivers\x86

Maybe this helps?
Thank you and kind regards

User avatar
Radi - Tracker Supp
Site Admin
Posts: 388
Joined: Tue Mar 03, 2015 12:46 pm

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Radi - Tracker Supp » Fri Apr 22, 2016 6:58 am

Hello cokolade,

It seems like the .bat file didn't copy the .dll file correctly. Please extract the archive from the KB Will sent you and try to copy the .dll file manually in the appropriate folder according to your OS version:

32-bit Windows: copy the 32-bit version of the DLL (/W32X86/XPSSVCS.DLL) in this folder: C:\Windows\System32\spool\drivers\W32X86\3
64-bit Windows: copy the 64-bit version of the DLL (/x64/XPSSVCS.DLL) in this folder: C:\Windows\System32\spool\drivers\x64\3

Regards,
Radi

jotagoman
User
Posts: 9
Joined: Fri Apr 22, 2016 4:38 pm

Re: PDF XChange Lite V6 error when printing after upgrade

Post by jotagoman » Fri Apr 22, 2016 5:00 pm

I had the same error code for Win 10 pro (x64) and th X-change Printer lite V6.

I manually installed the missing *.dll file (see http://www.tracker-software.com/knowled ... ot-working) and everything seems to be working fine (finally).

I guess Tracker software guys are going to make this fix available in the standard installation executable.

P.D: The only thing I still see is that when one wants to overwrite a printed file the Dialog box is shown in English ( I use the UI in French). I hope that can be corrected soon .

User avatar
Will - Tracker Supp
Site Admin
Posts: 6806
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Will - Tracker Supp » Mon Apr 25, 2016 4:23 pm

Hi jotagoman,

Thanks for the post - we will do what we can to fix the problem, but the issue is not ours and is happening because Windows does not correctly install the XPS engine. The MS XPS printer works because (strangely) it does not actually rely on those DLL's.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

cokolade
User
Posts: 12
Joined: Fri Apr 08, 2016 9:45 am

Re: PDF XChange Lite V6 error when printing after upgrade

Post by cokolade » Sun May 08, 2016 1:20 pm

Hi Radi,
Now I finally could come back again to this topic. I followed your instructions (probably similar to those of jotagoman) to manually copy the dll files - and it worked, great! Wow! I even do not see jotagoman's language problems. The dialogues are in my standard language German.

So the problem is fixed for me. Thank you very much to everybody (and I hope that Tracker can avoid this kind of problem for futire updates).

User avatar
Will - Tracker Supp
Site Admin
Posts: 6806
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: PDF XChange Lite V6 error when printing after upgrade

Post by Will - Tracker Supp » Mon May 09, 2016 12:48 am

:)
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

Post Reply