Focus bug (V. 307.1)

Forum for the PDF-XChange Editor - Free and Licensed Versions

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Paul - Tracker Supp, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Focus bug (V. 307.1)

Post by PeterPan » Wed Jan 29, 2014 3:04 pm

Hi,

I found the following bug while using the editor:
When I open a few pdf files in one window and read a few slides, switch to my Browser (Chrome) and then switch back, I'm still able to scroll with my mouse whell but I'm not able the use the arrow keys because the current tab hasn't got the focus. But I'm not able to reproduce this bug everytime I try.

I didn't want to create a new thread just for this topic but I have a feature request.
In the good old viewer you could press your mouse wheel, keep it pressed and scroll all over the pdf file, thats a small feature but I would love to see it again because I'm using it everyday. I'm very glad you already addes so many shortcuts but I still misses the shortcut Ctr + Tab to change Tabs. As far as I know you can't add this shortcut with the command menu?!

Keep up the great work and thank you very much for this great product.

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Wed Jan 29, 2014 7:29 pm

Hi PeterPan,

Thanks for the post - the Ctrl Tab option is something that is known and we intend to add it back into either build 307.2 or 308.

As for the focus issue, this isn't something that I'm experiencing here. With a reliable way to reproduce this issue, I'm afraid that we likely won't be able to help. If you do find a way to reproduce this, the please let me know and we'll dig deeper.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Thu Jan 30, 2014 5:00 pm

I tried a bit and now I'm able to reproduce this bug.

You have to do the following things, sounds strange but the bug shows like that:
1. Open Chrome
2. Open a few tabs and surf, then open another tab, for example http://www.google.de
3. Open the pdf editor with clicking on the symbol on the taskbar below
4. Open at least two pdfs in tabs and focus the second one
5. Click on Chrome at the taskbar and open a new (yeah, another one) tab with Crtl + T, surf to http://www.google.de
6. Click in the serach field a few times, click on the white space next to it and click again in the search field
7. Click on the pdf editor symbol in the task bar

The current tab won't be active but you can scroll with your mouse

I reall hope that you can reproduce it with the behaviour, even it sounds strange

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Thu Jan 30, 2014 6:29 pm

Hi PeterPan,

Thanks for getting back to me - I'm afraid that I'm not seeing any strange behaviour at all. Can you send screen-shots of what you're doing? If at all possible, perhaps a video of your process?

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Thu Jan 30, 2014 7:41 pm

Hi Will,

thanks for your response.
In the next 10 minutes you or your colleague should get an email with a short description, the video and the link to this thread.

PeterPan

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Thu Jan 30, 2014 8:00 pm

Hi PeterPan,

Thanks for sending that - I will take a look at the video and attempt to reproduce the issue, then will post back here with the restults.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Fri Jan 31, 2014 6:04 pm

Hi PeterPan,

Thanks for waiting - I've taken a look at the video and still am unable to reproduce the issue.

Can you tell me what OS you're running and what Version of Chrome?

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Fri Jan 31, 2014 6:41 pm

Hi Will,

thanks four your answer. I'm using Windows 8.1 64bit. The browser used in this video was Chrome 33.0.1750.58 beta-m. I know this is a beta version so I tried to reproduce it with Firefox (v. 26) and there was the same problem. So it doesn't seem to be related to the browser.
I have to say that I'm glad that you saw the video so you know there is a bug and it's not me :wink:

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Mon Feb 03, 2014 5:36 pm

Hi PeterPan,

Thanks for the additional info. - I'm also running the beta, but as you said previously, this is also linked to other browsers. It may be something that is specific to Windows 8.1. I'll have to test this on a Windows 8.1 VM, so I'll report back as soon as I know more.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Mon Feb 03, 2014 6:18 pm

Hi Will,

thanks, I'm curious what you will find out.

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Tue Feb 04, 2014 11:28 pm

Hi Peter,

thanks for waiting - I'm afraid that I'm still not able to reproduce this at all. Please make sure of all of the following:

1) You have the latest build of the Editor:
http://www.tracker-software.com/PDFXVE3.zip

2) You have the latest stable versions of all of the internet
browsers that this is happening with.

3) You have all of the necessary Microsoft updates//service packs.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Wed Feb 05, 2014 9:24 am

Hi Will,

All you mentioned applies.
But I really wanted to find out more about this bug so I tried to reproduce it another way.

I killed all processes which weren't related to my operating system (Windows 8.1 64bit) and then I tried again.
I found out that this bug/behaviour wasn't related to the browser as I first thought. I just needed the editor.

You can try to reproduce the bug the following way (you are just allowed to use your mouse, not your keyboard!):
1. Open the editor
2. Open one document
3. Minimize the editor with clicking on the editor symbol in the taskbar
4. Click it again to maximize it
5. The current tab is not active anymore

If somebody else reads this thread, maybe he can try to reproduce this behaviour. You can try it in less then 1 minute and I really would love to hear if somebody else has this problem too.

Cheers

PS: I wrote you an email again with another video

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13662
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Focus bug (V. 307.1)

Post by Tracker Supp-Stefan » Wed Feb 05, 2014 1:23 pm

Hi Kris,

Thanks for the sample video. Indeed the yellow highlight disappears, but at least on my machine this is still the active tab and I can scroll the document or it's thumbnails etc. So for me it's mostly a visual bug at this moment. Can you please tell us if it's causing you other problems other than the missing highlight?

Regards,
Stefan

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Wed Feb 05, 2014 1:30 pm

Hi Stefan,

Thanks a lot for your answer! My bad, I just tried with the arrow keys the whole time and didn't try any other shortcut. So the only problem for me is that I'm not able to use the arrow keys to scroll through the document. Scrolling with the mouse wheel and using other shortcuts seems to work.
It looks like it's something between a visual bug and a "real" bug. :wink:

Do you can use the arrow keys? Maybe I find some more shortcuts/keys that don't work.

Cheers

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13662
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Focus bug (V. 307.1)

Post by Tracker Supp-Stefan » Wed Feb 05, 2014 1:43 pm

Hi Kris,

You are right - the arrow keys don't work but the mouse does. I can use e.g. Alt-F to access the Main Menu -> File, though can't use keyboard keys to interact with the actual PDF itself. Now that's a "proper" bug ;) and I will report it to the devs.

Regards,
Stefan

PeterPan
User
Posts: 83
Joined: Tue May 31, 2011 6:56 pm

Re: Focus bug (V. 307.1)

Post by PeterPan » Wed Feb 05, 2014 1:49 pm

Hi Stefan,

thank you very much for your help. I think my description was a bit complicated at the beginning, luckily you understood what I meant. :D

Cheers

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Wed Feb 05, 2014 5:08 pm

Hi guys,

Stefan - glad that you reproduced the issue, as I still can't, even with the new instructions! (more than a little frustrating!)

Thanks for persevering through this - now that we've reproduced the issue, we should have no trouble fixing it.

Cheers,
Will
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

User avatar
Will - Tracker Supp
Site Admin
Posts: 6819
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Focus bug (V. 307.1)

Post by Will - Tracker Supp » Wed Feb 05, 2014 11:35 pm

Hi PeterPan,

Just to let you know, the ticket for this issue is RT-2297, so please reference this number if requesting updates, or you find the issue unresolved in later builds.

HTH!
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

Post Reply