invalid printer name detected!

This Forum is for the use of Software Developers requiring help and assistance for Tracker Software's PDF-XChange Printer Drivers SDK (only) - Please use the PDF-Tools SDK Forum for Library DLL assistance.

Moderators: Tracker Support, TrackerSupp-Daniel, Chris - Tracker Supp, Vasyl-Tracker Dev Team, Sean - Tracker, Andrew - Tracker Support, Tracker - Clarion Support, John - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software, Support Staff, moderators

Post Reply
myintuition
User
Posts: 4
Joined: Sat Oct 06, 2007 4:17 am

invalid printer name detected!

Post by myintuition » Sat Oct 06, 2007 1:07 pm

I have been using your activex driver for several years and it is great.
But lately I have been having some issues.

We upgraded to oracle 10 and I believe that Oracle must be using some of the same dlls's that the pdfxchange is using causing conflicts.

So, to ignore my application as it is way to complicated.
I open your DrvActiveX sample with Delphi. (No oracle, but I know that the oracle directory is in my path).
I run it and I get the same message my application gets.
invalid printer name detected!

So I went to the bin directory and copied all the dll's into the sample directory and the message did not go away.

Please help, soon.

Thanks
Karen

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Sun Oct 07, 2007 1:00 am

Hi Karen,

may I ask what build of PDF-XChange you are now using?
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

myintuition
User
Posts: 4
Joined: Sat Oct 06, 2007 4:17 am

Post by myintuition » Sun Oct 07, 2007 3:40 am

Version 3.5 build 0096

I did upgrade to the newest, but my code did not work.
I did not look into what I needed to do to make it work.
I really can not afford to upgrade every user at this point.
So I uninstalled the newest and reinstalled this version.

Karen

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Mon Oct 08, 2007 5:25 pm

Hi Karen,

I would be surprised if it is dll related to be honest.

We are going to need a code snippet to allow us to provide help - specifically what you are doing and how.

Also - I assume that this is being run locally and not from a server and that bothg the driver and Ax are installed on the system on which your app calls the printer ?
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

myintuition
User
Posts: 4
Joined: Sat Oct 06, 2007 4:17 am

Post by myintuition » Mon Oct 08, 2007 6:02 pm

John, I am using your sample code in the apidriver directory for delphi.
It works the same as my applications.
The pdf's work, but everytime begin doc is called, I get the above message.
I do get the pdf printout so it is just that the message is really annoying.

Again, I am using your sample code.
This has worked for us for years until we installed oracle 10.2 client.

Karen

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Mon Oct 08, 2007 7:11 pm

Ok Thanks karen - can I ask have you modified the printer name at all and if so - to what ?
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

myintuition
User
Posts: 4
Joined: Sat Oct 06, 2007 4:17 am

Post by myintuition » Mon Oct 08, 2007 8:07 pm

Nope, nothing has been modified.

The error happens as soon as BeginDoc is called.

Thanks
Karen

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Tue Oct 09, 2007 3:31 pm

Hi Karen,

We really do need you to check and use the latest release as we cannot see why this would be a problem - what was the issue when you attempted to use the latest release ?
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

Post Reply