Page 1 of 1

Policy not Working

Posted: Fri Feb 01, 2019 5:15 pm
by willyg

I've tried applying policy on PDF-XChange Editor v7.0.328.2 x64 (installed on Windows 7 Pro) via provided templates.
Policy settings are successfully appeared in HKLM\SOFTWARE\Policies\Tracker Software\PDFXEditor\3.0\ but have no effect on application.

See screenshots:

Re: Policy not Working

Posted: Fri Feb 01, 2019 6:09 pm
by TrackerSupp-Daniel
Hello Willy,

I have moved this post to its own topic as it was in a thread dedicated to feature requests, not troubleshooting.
Our Systems specialist is looking into this for you currently, and should return with a reply for you later today.

Kind regards,

Re: Policy not Working

Posted: Fri Feb 01, 2019 6:39 pm
by Paul - Tracker Supp
Hi Willy,

we have reproduced the issue and are investigating now.

Thanks for bringing this to our attention.

Re: Policy not Working

Posted: Tue Feb 26, 2019 3:32 pm
by fwedvteam
Hi @all,

are there any news to this issue? We have the same problem and it looks like, that java script is "automaticaly" enabled. I have workarround it by using HKCU key settings.


Re: Policy not Working

Posted: Mon Mar 04, 2019 2:12 pm
by willyg

Same question here. Any news?

Re: Policy not Working

Posted: Mon Mar 04, 2019 4:01 pm
by Paul - Tracker Supp
Hi guys,

indeed the issue has been reproduced however it seems that it is still not addressed. To that end I have created a support request ticket. While internal only, you can refer to RT#4685: Editor not respecting Group Policy settings and get a status update.

My apology for the tardiness on this, I did reproduce the issue and bring it to the team however I did not make the associated ticket. The ticket is in the system now and should be dealt with in short order.

Again my apologies for dropping the ball on this one.

Re: Policy not Working

Posted: Mon Mar 04, 2019 6:49 pm
by willyg
It's ok. Thank you for assistance.

Re: Policy not Working

Posted: Tue Mar 05, 2019 8:13 am
by Radi - Tracker Supp

Re: Policy not Working

Posted: Mon Mar 11, 2019 3:20 pm
by Paul - Tracker Supp
Hi Willy,

I got a response on the ticket that it was rejected. When I said I had reproduced the issue, I applied a policy and looked to see the settings changes reflected in the Editor and they were not. What I did not do however was actually test the functionality with this policy in place.

I set the exact same settings as you Willy, and the settings are applied to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Tracker Software\PDFXEditor\3.0\JavaScript as were yours:
and as per your post the settings do not change in the Editor preferences, however, when I went and tested this they are working for me. Can you try opening this PDF for example? ... lendar.pdf

Whit the exact same settings as you, I find that the combination of Disable JavaScript Actions and Disabling the warning on execute has the effect that the JS is blocked and the user cannot use it.

Do you see the same?

It seems to me that the issue is not that the Policy does not work, but that it does not get reflected in the Editor's settings. In the words of the lead developer:
"The Editor does respect group policy settings,[...] if the GPO value is not reflected in the Preferences, [...] we have no intention to do so, because structure of GPO is different than the UI preferences."
Essentially he is saying the policy works, just do not expect to see it in the user's preferences. Can you confirm this on your end with that URL for example?

Re: Policy not Working

Posted: Wed Mar 20, 2019 3:27 pm
by willyg

Sorry for delay.

Wow, you're right: policy is working but not reflected in the UI.
This indeed is very misleading behavior both for users, admins and Tracker support ;)
When something contradicts all previous experience, one's first thought is "this applications is buggy" which isn't very good for reputation.

Please reconsider the decision of not reflecting GPO-controlled settings in UI.

Thank you.

PS. Maybe it's time to move this post back to GPO feature request topic :)

Re: Policy not Working

Posted: Wed Mar 20, 2019 3:39 pm
by Paul - Tracker Supp
Hi Willy,

thanks for confirming that it works despite the settings in the UI.

I appreciate the feedback. I will definitely bring it to the team. My understanding is that it is not trivial to change else it would have already.

I agree that it would be better for the settings to be reflected, right now it is a challenge, we will have further discussion about it internally.