Setting Form Field formatting to None

PDF-XChange Editor SDK for Developers

Moderators: TrackerSupp-Daniel, Tracker Support, Chris - Tracker Supp, Vasyl-Tracker Dev Team, Sean - Tracker, Paul - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Forum rules
DO NOT post your license/serial key, or your activation code - these forums, and all posts within, are public and we will be forced to immediately deactivate your license.

When experiencing some errors, use the IAUX_Inst::FormatHRESULT method to see their description and include it in your post along with the error code.
Post Reply
prime clinical systems
User
Posts: 211
Joined: Sun Aug 05, 2012 5:20 pm

Setting Form Field formatting to None

Post by prime clinical systems » Wed Nov 24, 2021 6:22 pm

Hi, I have several fields in PDF that have Date type formatting, and I want to set to None in code, as shown in the combo. I see these flags, but nothing that says None.

TFF_Date = 2048,
TFF_MultiLine = 4096,
TFF_Password = 8192,
TFF_FileSelect = 1048576,
TFF_DoNotSpellCheck = 4194304,
TFF_DoNotScroll = 8388608,
TFF_Comb = 16777216,
TFF_RichText = 33554432,
TFF_RTL = 268435456,

Thanks

User avatar
Ivan - Tracker Software
Site Admin
Posts: 3469
Joined: Thu Jul 08, 2004 10:36 pm
Location: Vancouver Island - Canada
Contact:

Re: Setting Form Field formatting to None

Post by Ivan - Tracker Software » Wed Nov 24, 2021 7:59 pm

Date (or any other type of formatting) is not described by form field flags.
Instead, Format/Keystroke actions are used. You will have to remove these actions. Something like this

Code: Select all

pField->put_Actions(Trigger_Format, nullptr);
pField->put_Actions(Trigger_Keystroke, nullptr);
pField->put_Actions(Trigger_Validate, nullptr);
Tracker Software (Project Director)

When attaching files to any message - please ensure they are archived and posted as a .ZIP, .RAR or .7z format - or they will not be posted - thanks.

Post Reply