PDX-XChange command line printing to printer from different paper trays in Windows

Forum for the PDF-XChange Editor - Free and Licensed Versions

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Paul - Tracker Supp, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
User avatar
hans.christiansen
User
Posts: 1
Joined: Thu Feb 14, 2019 3:12 pm

PDX-XChange command line printing to printer from different paper trays in Windows

Post by hans.christiansen » Thu Feb 14, 2019 3:59 pm

Hi,
I am attempting to use the printing of pdf files using PDF-XChange Plus (Version 7.0 build 327.1) via the command line and have come across a problem.

I have two printers: "RICOH Aficio MP C3000" and "RICOH Aficio MP C3000 (MultiTray)" setup on my computer. The first one is set to use the standard A4 tray whereas the second printer is the same device but setup to select the manual/multitray.

Printing test pages from the properties window of each printer sends the output to the right tray/paper.

However when requesting a pdf be printed using the command line switches shown below it only ever uses the standard tray when printing.

Calling:

Code: Select all

"c:/Program Files/Tracker Software/PDF Editor/PDFXEdit.exe" /print:copies=2^&showui=no^&printer="RICOH Aficio MP C3000" testfile.pdf
results in the printout correctly directed to the standard tray, whereas the next call:

Code: Select all

"c:/Program Files/Tracker Software/PDF Editor/PDFXEdit.exe" /print:copies=2^&showui=no^&printer="RICOH Aficio MP C3000 (MultiTray)" testfile.pdf
should use the manual/multitray paper source - but doesn't - it gets sent to the standard tray.

The printout ends up in the correct queue when printed. Seems that PDF-XChange is forcing the printout to inherit the settings from the standard printer!

Interesting to note is that opening the document in PDF-XCHange Plus and there selecting Print and each printer manually then the output is printed on paper from the correct source!

Would be grateful for ideas as to why this happens when using the command line switches.

Thanks

Post Reply