Page 1 of 1

Auto-select newly created comments

Posted: Sat Oct 27, 2018 5:31 pm
by Arnold
I have "Auto-select newly created comment" enabled in Preferences. This no longer seems to work with the Typewriter tool or the Text Box tool. The last build it seems to have worked with was 325.1. Is this by design?

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 11:53 am
by Dimitar - Tracker Supp
Hello Arnold,

I have just tested it on version 7.0.327.1 and it seems to work just fine at my end.

Could you please give us more details about the computer workstation you are using?

Regards.

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 3:38 pm
by Arnold
It happens with Windows XP sp3 and Windows 7 sp1. If I type something with the Typewriter tool or in a Text Box and hit escape I get a different result with 327.1 than I used to. That was helpful when filling out long forms.

I reset settings and tried it to see if it was my settings that caused it, but same results.
325.1 Typewriter.png
325.1 Typewriter.png (5.17 KiB) Viewed 3124 times
327.1 Typewriter.png
327.1 Text Box.png
327.1 Text Box.png (3.84 KiB) Viewed 3124 times
325.1 Text Box.png
325.1 Text Box.png (3.71 KiB) Viewed 3124 times

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 5:20 pm
by TrackerSupp-Daniel
Hello Arnold,

I've just done a comparison between 327.1, 325.1, and V6 build 322.7, to see how the handling could have changed. In all cases, placing the typewriter field selected the new field, and allowed typing directly into it, pressing escape would back out and allow movement of the field, and altering of the format, and pressing Tab allowed me to switch to the next object/field.

Could you please detail what aspect here is not working correctly on your machine? From the screenshots you have sent, it all looks to be in order and unchanged from prior handling. Perhaps a gif or detailed step by step process would be beneficial.

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 6:45 pm
by Arnold
Please look at the screenshots, the 325.1 boxes are "automatically selected" as set in preferences and the 327.1 ones are not.

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 8:19 pm
by TrackerSupp-Daniel
HI Arnold,

Apologies, I didn't even notice the missing handles in my earlier test!
It seems that they appear as soon as any interaction is detected (arrow keys for example) so the unit is selected, the handles are simply missing. I am making a bug report on this now:
RT#4546: Handles missing from "auto selected comments"

Have a great day!

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 8:51 pm
by Arnold
No problem. Should have spotted that it was just the handles missing myself. Saturday was the 1st time in a while I have had to fill out a form of any size. I think the handles show up on lines, arrows, etc.

I really like the new "Nudge" settings introduced in this build.

Thanks.

Re: Auto-select newly created comments

Posted: Mon Oct 29, 2018 9:33 pm
by TrackerSupp-Daniel
:)

Re: Auto-select newly created comments

Posted: Tue Dec 25, 2018 5:05 am
by Arnold
The main problem was fixed with the release of 328.1. Thank you. I find that the selection handles still disappear with the "super" Nudge feature/shortcut. The handles do not disappear when I use the "regular" and "micro" Nudge shortcuts.

To reproduce it, use the Typewriter feature and create some text. Then use the Escape key so that the selection handles appear. The use of Shift/Arrow (super Nudge) keys to move the text causes the handles to disappear. The text can still be moved but the handles are gone.

However, the behavior disappears if the text is first completely deselected and then re-selected. Happens over here in both Windows XP and 7.

Thanks.

Re: Auto-select newly created comments

Posted: Thu Dec 27, 2018 2:31 pm
by Dimitar - Tracker Supp
Hello Arnold,

Is it possible to create a video clip of what you see at your end because I cannot reproduce this behavior?

Regards.

Re: Auto-select newly created comments

Posted: Thu Dec 27, 2018 3:59 pm
by Arnold
Here is what happens over here in 3 steps
Use Typewriter or Text Box to create text
Press Escape key 1 time and handles appear
Press Shift key and handles disappear (text can still be moved using arrow keys)

However
Use Typewriter or Text Box to create text
Press Escape key 3 times to completely deselect text
Select text again and handles re-appear
Press Shift key and handles do not disappear

Re: Auto-select newly created comments

Posted: Fri Dec 28, 2018 12:33 pm
by Dimitar - Tracker Supp
Hello Arnold,

Unfortunately, the behavior of the Typewriter tool is completely different at my end.

I will install the PDF Editor on my Windows 7 and test it there.


Regards.

Re: Auto-select newly created comments

Posted: Fri Dec 28, 2018 2:06 pm
by Arnold
I reset the settings on the XP machine and tried it to see if that made a difference and it did not. Have not tried that on Windows 7, but I am pretty sure it will not make a difference on that machine either.

Thanks.

Re: Auto-select newly created comments

Posted: Fri Dec 28, 2018 3:30 pm
by Dimitar - Tracker Supp
Hello Arnold,

I tested it on Windows 7, but I still can not reproduce the problem at my end.

The main difference comes when I press escape.

Could you please export the settings of your PDF Editor and send the file to us?

Please send them to: support@tracker-software.com

Regards.

Re: Auto-select newly created comments

Posted: Fri Dec 28, 2018 3:42 pm
by Willy Van Nuffel
Something related to Keep Selected and Exclusive Mode that are both ON ?

In that case I'm missing the handles too (V7.328.1).

Re: Auto-select newly created comments

Posted: Fri Dec 28, 2018 8:22 pm
by TrackerSupp-Daniel
Hello All,

Thank you for the tip Willy, I have managed to reproduce it, and it does seem that the "exclusive mode" + "keep selected" is the cause. I have forwarded this finding to the dev team for investigation.
I cannot provide a timeline for the fix, but know that it is in the works!

Re: Auto-select newly created comments

Posted: Fri Dec 28, 2018 11:56 pm
by Arnold
I think it's possible that what Willie found may not be the whole problem, as I don't believe I have Exclusive mode turned on. Attached is my settings file for you guys to test with. I exported the settings without signature or spell checker info (last 4 check boxes).

Thanks.

Re: Auto-select newly created comments

Posted: Sat Dec 29, 2018 12:04 am
by TrackerSupp-Daniel
Hello Arnold,
Thank you for exporting your settings, I could not reproduce it with the typewriter tool in your settings, the selection box worked as intended.
DMKB18December1054.png
DMKB18December1054.png (11.58 KiB) Viewed 2642 times
Which tool were you using that showed the error?

Re: Auto-select newly created comments

Posted: Sat Dec 29, 2018 1:38 am
by Arnold
With either the Typewriter tool or the Text Box tool. I create either one, then simply press Escape so the handles appear. Then if I use the "super" Nudge feature (Shift/Arrow Keys) the handles disappear. I can move the boxes around just fine using Shift/Arrow Key, but the minute I press the Shift key the handles disappear. So the feature works okay, but the handles disappear. It appears to be the Shift portion of the shortcut that causes it.

I just tried it in version 6 (322.7) portable with my version 6 settings on XP and version 6 portable with what looks like default settings on 7, and the behavior is the same. Shift/Arrow Key works just fine, but the handles are missing as long as the Shift key is depressed. I also find the same thing in version 6 where if I completely deselect the box, then re-select it, the handles do not disappear when I depress the Shift key. The behavior is different.

That is the best I know how to describe it.

Re: Auto-select newly created comments

Posted: Sat Dec 29, 2018 10:59 am
by Willy Van Nuffel
Hello Arnold and Tracker Software Support,

I checked with the settings-file here above and I can reproduce the problem.

When I press the Shift key, the handles disappear.

I can only explain this by the fact that "Keep Selected" is active in Arnold's settings.

Actions to check this:
- click the Comment-tab
- in the Comment-ribbon, click the Text Box icon
- click the Format-tab
- in the Format-ribbon, you will see that the Keep Selected button is active

Once you de-activate the Keep Selected button, the handles for the Text Box will NOT disappear anymore when you press the Shift key.

Regards.

Re: Auto-select newly created comments

Posted: Sun Dec 30, 2018 1:10 am
by Arnold
One other thing that I have noticed. Don't know if this ties in. Steps below to recreate.

Create text using Typewriter or Text Box
Press Escape key 3 times to completely deselect box
Move cursor over box and hand automatically changes to a pointer (arrow) to allow box to be selected

However if the Shift key is pressed while the cursor is over the box, the hand no longer becomes a pointer and the box cannot be selected

Windows XP and 7

Re: Auto-select newly created comments

Posted: Mon Dec 31, 2018 4:25 pm
by Paul - Tracker Supp
Hey guys,

as far as I can tell the functionality is correct, it is just that sometimes while holding the shift key the handles disappear? But the arrows still nudge correctly?

It did appear to me to behave differently if selecting the text Boxes directly with the mouse on the page vs selecting the same text boxes via the comments pane. The latter seems to me to behave as expected.

Is that also what you see?

Re: Auto-select newly created comments

Posted: Tue Jan 01, 2019 2:25 am
by Arnold
To add to my last post. If the Shift key is pressed it prevents the normal cursor - Hand, Typewriter, Text Box - from changing to a selection pointer under all scenarios it seems. This prevents the selection of the box using the mouse.

So the Shift key causes selection handles to be hidden under certain conditions, and also prevents the selection of the box with the mouse.

2018-12-31 21_08_05-New Document_ - PDF-XChange Editor.png

Re: Auto-select newly created comments

Posted: Thu Jan 03, 2019 12:06 am
by TrackerSupp-Daniel
Hello All,

The shift key toggles "exclusive mode" temporarily, which is what causes the mouse to be unable to interact with any items, as it is intended to allow placement without interference. This is an intended function.

It seems that hiding the handles while shift is held was intentional. As was suspected, exclusive mode causes this when a tool is still selected. It turns out that the only actual "bug" here is that the Hand tool does not work as all the others do. When exclusive mode is on nothing can interact with comments (not even the currently selected one), this includes the hand tool, as such you will find that when those handles do appear, you still cannot use them as the Editor thinks you are interacting with the page below them.

I hope this helps!