Broken links in the builds archive

Forum for the PDF-XChange Editor - Free and Licensed Versions

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Paul - Tracker Supp, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
ArchStanton
User
Posts: 48
Joined: Tue May 26, 2015 2:54 pm

Broken links in the builds archive

Post by ArchStanton » Fri Jun 29, 2018 6:47 pm

Hello, I wanted to download PDF XChange Editor v. 5.5.316.1 Portable, but the link [1] in the builds archive is broken (as are others regarding older versions). Could you please fix it or upload the file here? If you have them at hand, it would be great if I could get my hands on all the types of installer of that version (portable without OCR, exe, msi's...). (They are my benchmarks for how well the Editor runs on Ubuntu.) Thank you very much.

1 http://www.docu-track.co.uk/builds/5.5. ... rtable.zip

HaPe
User
Posts: 160
Joined: Wed Oct 29, 2014 9:34 pm

Re: Broken links in the builds archive

Post by HaPe » Fri Jun 29, 2018 8:00 pm

@ArchStanton,
your link seems to be working on my machine: I'm offered to download and save the file (I cancelled the download half-way)
Here is another link that might work for you:
https://www.tracker-software.com/versio ... nge-editor

HaPe

User avatar
TrackerSupp-Daniel
Site Admin
Posts: 3427
Joined: Wed Jan 03, 2018 6:52 pm

Re: Broken links in the builds archive

Post by TrackerSupp-Daniel » Fri Jun 29, 2018 8:22 pm

Hello Everyone,
Terribly sorry, I meant to post, but instead just acted!
I've spoken with our team and had the links fixed for you.
Enjoy!
Daniel McIntyre
Support Technician
Tracker Software Products (Canada) LTD

Support: <Support@tracker-software.com>
Sales: +1 (250) 324-1621
Fax: +1 (250) 324-1623

ArchStanton
User
Posts: 48
Joined: Tue May 26, 2015 2:54 pm

Re: Broken links in the builds archive

Post by ArchStanton » Sat Jun 30, 2018 9:08 am

I'm on Firefox 60.0.2, my OS is Ubuntu 18.04.
I can't imagine why but the links work on Firefox's private mode, but they keep redirecting me to https://www.tracker-software.com/ in "normal mode". I tried deleting the cookies from forum.tracker-software.com but it didn't do anything. I don't know if this bug is on my side and I'm happy with the private mode workaround, so for me the issue might as well be considered solved. Thanks for the help :-)

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 14023
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Broken links in the builds archive

Post by Tracker Supp-Stefan » Mon Jul 02, 2018 10:42 am

Hello ArchStanton,

Strange that it does not want to work in one of your browsers, but the files are certainly on the server and accessible with the links like in your original post.
Do you have some firewall or helper tools in the froblematic FF that could be causing this?

Cheers,
Stefan

ArchStanton
User
Posts: 48
Joined: Tue May 26, 2015 2:54 pm

Re: Broken links in the builds archive

Post by ArchStanton » Tue Jul 03, 2018 9:34 am

I don't know what it is. I don't have firewalls or other things that may interfere (at least not that I know of). I've tried FF in safe mode and it behaves like in normal mode: http://www.docu-track.co.uk/builds/5.5. ... rtable.zip and http://www.docu-track.co.uk/builds/5.5. ... rtable.zip don't work. In private mode only the link to v5.5.314.0 Portable doesn't work (of the few that I have tested). :?

User avatar
Will - Tracker Supp
Site Admin
Posts: 6905
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Broken links in the builds archive

Post by Will - Tracker Supp » Tue Jul 03, 2018 11:08 am

Hi Arch,

I'm using 60.02 myself and don't have an issue. I'm also working from home so my IP isn't being treated any differently from yours. The only difference is the OS, which is a possible cause, or something else interfering. Do you have any antivirus that might do that? Or a VPN service running?

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

ArchStanton
User
Posts: 48
Joined: Tue May 26, 2015 2:54 pm

Re: Broken links in the builds archive

Post by ArchStanton » Tue Jul 03, 2018 3:22 pm

Will - Tracker Supp wrote: Do you have any antivirus that might do that? Or a VPN service running?
None of that.

User avatar
TrackerSupp-Daniel
Site Admin
Posts: 3427
Joined: Wed Jan 03, 2018 6:52 pm

Re: Broken links in the builds archive

Post by TrackerSupp-Daniel » Tue Jul 03, 2018 6:14 pm

Hello Archstanton,
It is also possible your ISP may offer automated VPN services, if you do not mind my asking, who is your current internet service provider?
Daniel McIntyre
Support Technician
Tracker Software Products (Canada) LTD

Support: <Support@tracker-software.com>
Sales: +1 (250) 324-1621
Fax: +1 (250) 324-1623

ArchStanton
User
Posts: 48
Joined: Tue May 26, 2015 2:54 pm

Re: Broken links in the builds archive

Post by ArchStanton » Wed Jul 04, 2018 11:15 am

I tried my home wi-fi (Fastweb), and using my phone as hotspot (TIM). These are italian ISPs.

Edit: Tested also on Eduroam. With FF in normal mode I'm always redirected to the home page from the links above.

User avatar
Will - Tracker Supp
Site Admin
Posts: 6905
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Broken links in the builds archive

Post by Will - Tracker Supp » Wed Jul 04, 2018 1:55 pm

Hi Arch,

I've also used Eduroam to access the site, but without issue. The fact that it happens irrespective of the WiFi you're using, or happens for you on a WiFi network that I've also used, but doesn't happen for me, definitely says that this is an issue local to your PC.

All I can suggest is checking your proxies, antivirus, Firefox settings, etc.. Other than that, there's nothing that we can do here as there's no issue with the site. It might also be worth contacting Mozilla (if that's even possible these days) and letting them know, because it could just as likely be a bug in Firefox that's only present on Linux systems, or with certain WiFi cards on certain systems, etc.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

ArchStanton
User
Posts: 48
Joined: Tue May 26, 2015 2:54 pm

Re: Broken links in the builds archive

Post by ArchStanton » Wed Jul 04, 2018 2:07 pm

Thanks Will, for the time being I'll just wait. If it gets fixed with an update I'll report back. Have a nice day, bye.

User avatar
Will - Tracker Supp
Site Admin
Posts: 6905
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: Broken links in the builds archive

Post by Will - Tracker Supp » Wed Jul 04, 2018 2:10 pm

No worries Arch, you too! :)
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

Post Reply