PDF-XChange - Tracker PDF Viewer - TIFF-XChange - Image-XChange - XMF-XChange - Raster-XChange - Support

Moderators: TrackerSupp-Daniel, Tracker Support, Chris - Tracker Supp, Vasyl-Tracker Dev Team, Paul - Tracker Supp, Ivan - Tracker Software, Sean - Tracker, Tracker Supp-Stefan

 
Msradell
User
Topic Author
Posts: 12
Joined: Fri Oct 07, 2016 3:38 am

Internet PDF links opening in IE

Sun Nov 26, 2017 2:30 am

I have a very strange situation. Starting about 2 weeks ago whenever I click on a link in IE11 it opens in IE instead of in Adobe or PDF-XChange Editor. I believe whatever is causing this is inside of PDF-XChange Editor because of the bar that's across the top of the screen when it opens. I'm attaching a screen capture of what I'm talking about.

I've looked through all of the settings that I can think of in PDF-XChange Editor and can't see any place that I can change this behavior.

Any help is certainly appreciated.

Capture.JPG
 
Willy Van Nuffel
User
Posts: 1260
Joined: Wed Jan 18, 2006 12:10 pm

Re: Internet PDF links opening in IE

Sun Nov 26, 2017 8:43 am

About how to make PDF-XChange Editor the default application for viewing for viewing PDF documents in Internet Explorer 11, is explained here:
(take care, the first part goes about PDF-XChange Viewer, the second part goes about PDF-XChange Editor)

https://www.tracker-software.com/knowle ... t-Explorer

You should just do the opposite:
- In PDF-XChange Editor : Edit-menu > Preferences > File Associations > View PDF files in Internet Explorer => NO + Apply + Yes + OK
- In Internet Explorer 11 : Tools-menu > Internet Options > Security-tab => activate Enable Protected Mode + OK, and restart IE11

Please come back to tell us if this works, or not.

Best regards.

NOTE:
I while ago, there was a whole thread about this kind of problem and it was only solved via a remote intervention by Tracker Software support:
viewtopic.php?f=62&t=29605&p=116767&hilit=browser+registry#p116767

Myself, I just did a test today. Adobe Reader has taken the hand over to open PDFs "in the browser" in Internet Explorer 11.
I can NOT get it to change this behavior. Still a mystery.
 
Msradell
User
Topic Author
Posts: 12
Joined: Fri Oct 07, 2016 3:38 am

Re: Internet PDF links opening in IE

Sun Nov 26, 2017 4:54 pm

It looks like I'm having the same problem you did when you tested it. When I open the file association section of preferences it shows in the current PDF application is Adobe Acrobat Reader DC and when I try to change any of the options they immediately revert you do not change as soon as I apply. I want DC reader to be my default because it's easier for quick reads and I have it set to default to my main screen directly in front of me. PDF-XChange Editor I use for viewing the many PDF drawings I get and have it set to display on my 2nd screen which is larger and higher resolution. It's much easier to use a measuring function on that screen.

I don't understand is why the PDF-XChange Editor bar is displaying a PDF documents that open on my primary screen??

Capture.JPG
 
Willy Van Nuffel
User
Posts: 1260
Joined: Wed Jan 18, 2006 12:10 pm

Re: Internet PDF links opening in IE

Sun Nov 26, 2017 8:52 pm

1) When you make changes in the File Associations dialog box, by selecting Yes or No at a particular option, you need to confirm that change.
It's a pitty that you can not see the current setting for each option. "Do not change" has no signification.

2) It seems that you really need to "disable" the Adobe Reader plugin in Internet Explorer 11 to make that PDFs are opening outside the browser in a separate window (mystery solved):
- https://helpx.adobe.com/acrobat/using/d ... owser.html

3) In case that PDFs are opening outside the browser, it depends of what application has been set in Windows File Explorer to open PDFs.
You can change this behavior - via Windows File Explorer - in the following way (as you probably know):
- do a right mouse click on a PDF
- select Open with > Choose an other app
- select PDF-XChange Editor or an other PDF-app
- mark the checkbox "Always use this app to open PDF files"
- click OK.

4) Myself, I do not correctly understand the question in your last sentence:
"I don't understand is why the PDF-XChange Editor bar is displaying a PDF documents that open on my primary screen??"
Do you mean that PDFs are opening with the Editor while Adobe Reader has been set as the default?
 
Msradell
User
Topic Author
Posts: 12
Joined: Fri Oct 07, 2016 3:38 am

Re: Internet PDF links opening in IE

Sun Nov 26, 2017 9:21 pm

It seems as if things are very confused in my set up.
1. After I selected option in the dialogue I click the apply box and it goes back to the "Do Not Change" dialogue, it doesn't appear to be accepting the changes I make.
2. I have the Adobe Reader plug-in disabled and have had for a long time yet PDF links still open within IE 11. If I open a PDF from my desktop it opens correctly in Adobe Reader.
3. I have Adobe Reader DC set as my default so that standard PDF documents open with it on my main screen. I use PDF-XChange Editor to view and change AutoCAD PDF files, it opens on my 2nd monitor which is larger and has high resolution.
4. To clarify, when I click a link to a PDF file on a website it opens within Internet Explorer 11 and it has the toolbar from PDF-XChange Editor along the top of it as shown in my earlier attachment.

When I click a PDF file that's on my desktop or in a directory it opens fine in Adobe Reader DC like it's supposed to. The problem develops whenever I open a PDF file from a link on a website. That's where things go squirrelly because I get the PDF-XChange Editor are with them as I open within IE it was I don't have any portion of PDF-XChange Editor associated with IE.

I hope maybe this explanation makes my problem a little clearer.
 
Willy Van Nuffel
User
Posts: 1260
Joined: Wed Jan 18, 2006 12:10 pm

Re: Internet PDF links opening in IE

Mon Nov 27, 2017 7:49 am

Please try again, like I mentioned before:
- In PDF-XChange Editor : Edit-menu > Preferences > File Associations > View PDF files in Internet Explorer => NO + Apply + Yes + OK
(After making changes, it is normal that the "Do not change" returns.)

If this does not help, then try by deleting the Windows registry keys that you can find in the other thread, I also mentioned before.

Best regards.
 
Msradell
User
Topic Author
Posts: 12
Joined: Fri Oct 07, 2016 3:38 am

Re: Internet PDF links opening in IE

Tue Nov 28, 2017 2:18 am

I resorted to deleting the registry key from the other thread and it finally solved the problem! Thanks so much for all your help.
 
Willy Van Nuffel
User
Posts: 1260
Joined: Wed Jan 18, 2006 12:10 pm

Re: Internet PDF links opening in IE

Tue Nov 28, 2017 8:22 am

Done with pleasure, and happy to read that your problem has been solved.

Best regards.
 
User avatar
Tracker Supp-Stefan
Site Admin
Posts: 12679
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Internet PDF links opening in IE

Wed Nov 29, 2017 4:04 pm

Many thanks for the help Willy!

Glad to hear the situation is resolved now!

Cheers,
Stefan

Who is online

Users browsing this forum: No registered users and 3 guests