Links within a document not working?

Forum for the PDF-XChange Editor - Free and Licensed Versions

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Paul - Tracker Supp, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
LarryLuciani
User
Posts: 8
Joined: Mon Nov 10, 2008 9:52 pm

Links within a document not working?

Post by LarryLuciani » Mon Dec 23, 2013 7:24 pm

One of our suppliers catalogues uses hyperlinks to move to the associated information on a different page. This did work with PDF viewer and still works with Adobe viewer 11 but no longer with Editor. Is there a setting that I have wrong? Seems like a fairly common application to not be working.

User avatar
Paul - Tracker Supp
Site Admin
Posts: 4944
Joined: Wed Mar 25, 2009 10:37 pm
Location: Chemainus, Canada
Contact:

Re: Links within a document not working?

Post by Paul - Tracker Supp » Mon Dec 23, 2013 7:43 pm

Hi Larry,

links in the Editor should also work. It depends perhaps on how those links were set up. Are you able to unload (in a zip archive) a sample that we can look at?

regards
_________________
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards

Paul O'Rorke
Tracker Support North America
http://www.tracker-software.com

LarryLuciani
User
Posts: 8
Joined: Mon Nov 10, 2008 9:52 pm

Re: Links within a document not working?

Post by LarryLuciani » Mon Dec 23, 2013 7:47 pm

I have attached a sample catalogue
Attachments
verb.zip
(1.38 MiB) Downloaded 49 times

User avatar
Paul - Tracker Supp
Site Admin
Posts: 4944
Joined: Wed Mar 25, 2009 10:37 pm
Location: Chemainus, Canada
Contact:

Re: Links within a document not working?

Post by Paul - Tracker Supp » Mon Dec 23, 2013 8:03 pm

Hi Larry,

these links seem to be working for me in the current build of the Editor. Do note that you need to have the "Hand Tool" selected for these to function.

Could that be the issue? Perhaps you had the "Select Tool" or some other Tool selected?

hth
_________________
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards

Paul O'Rorke
Tracker Support North America
http://www.tracker-software.com

LarryLuciani
User
Posts: 8
Joined: Mon Nov 10, 2008 9:52 pm

Re: Links within a document not working?

Post by LarryLuciani » Mon Dec 23, 2013 8:18 pm

Interesting. You are correct, if I have the hand tool selected the links work. I must have tried this at least ten different times and it never worked. Hard to believe that I had selected a different tool and not noticed. Did PDF viewer work the same way? I don't ever remember having the same issue. Did it change focus to know that it was a link and Editor doesn't?

User avatar
Paul - Tracker Supp
Site Admin
Posts: 4944
Joined: Wed Mar 25, 2009 10:37 pm
Location: Chemainus, Canada
Contact:

Re: Links within a document not working?

Post by Paul - Tracker Supp » Mon Dec 23, 2013 8:31 pm

Hi Larry,

indeed the Viewer would automatically switch to the Hand Tool if the Select Tool was the currently selected one and you moused over these links. The Editor will do the same if you have other Tools selected, Call out, Text Box etc but not the Select Tool. This is by design, many users said they wanted the Select Tool to be exclusive this way.

So the links should work with pretty much any tool other than the Select Tools you should see the mouse pointer switch to the Hand on mouse over, again except for when you have the Select Tool active.

I hope that helps.
_________________
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards

Paul O'Rorke
Tracker Support North America
http://www.tracker-software.com

LarryLuciani
User
Posts: 8
Joined: Mon Nov 10, 2008 9:52 pm

Re: Links within a document not working?

Post by LarryLuciani » Mon Dec 23, 2013 8:38 pm

I personally liked it the other way but at least now I know how it functions. Appreciate your help and enjoy the holidays!

User avatar
Paul - Tracker Supp
Site Admin
Posts: 4944
Joined: Wed Mar 25, 2009 10:37 pm
Location: Chemainus, Canada
Contact:

Re: Links within a document not working?

Post by Paul - Tracker Supp » Mon Dec 23, 2013 8:56 pm

Understood Larry,

I wish you and those close to you a most excellent festive season also!

regards
_________________
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards

Paul O'Rorke
Tracker Support North America
http://www.tracker-software.com

Post Reply