Spooler SubSystem App Error on Driver Install

PDF-XChange Drivers API (only) V4/V5
This Forum is for the use of Software Developers requiring help and assistance for Tracker Software's PDF-XChange Printer Drivers SDK (only) - VERSION 4 & 5 - Please use the PDF-Tools SDK Forum for Library DLL assistance.

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan

Post Reply
jeffp
User
Posts: 873
Joined: Wed Sep 30, 2009 6:53 pm

Spooler SubSystem App Error on Driver Install

Post by jeffp » Mon Jan 24, 2011 10:49 pm

We've had a few users report a Spooler SubSystem App error when installing your PDF Printer Driver (which we launch from out installer). I've attached some screen shots from one of our users who was running Windows 7 64bit.

I've actually seen it once or twice on my dev machine but then with the next install it goes away.

Have you seen this before? Any thoughts on what we can do here?

Below is a snippet of my commandline parameter that I pass to the driver exe. I use InnoSetup.

/VERYSILENT /NORESTART /COMPONENTS="pdfSaver,PDF-XChange driver" /DIR="%s" /PName="%s" "/Organization:FileCenter"
Attachments
Spooler Error.zip
(2.13 MiB) Downloaded 174 times

Ivan - Tracker Software
Site Admin
Posts: 3630
Joined: Thu Jul 08, 2004 10:36 pm
Location: Vancouver Island - Canada
Contact:

Re: Spooler SubSystem App Error on Driver Install

Post by Ivan - Tracker Software » Tue Jan 25, 2011 12:27 am

Jeff - this is your real command line? Including "%s" ? :?:

Please provide information regarding the version of the driver you are trying to install and the specific exe as well - thanks
Tracker Software (Project Director)

When attaching files to any message - please ensure they are archived and posted as a .ZIP, .RAR or .7z format - or they will not be posted - thanks.

jeffp
User
Posts: 873
Joined: Wed Sep 30, 2009 6:53 pm

Re: Spooler SubSystem App Error on Driver Install

Post by jeffp » Tue Jan 25, 2011 2:09 pm

I using the PDFXSA_sm.exe downloaded from your site. The version is 4.0.191.0.

The "%s" in my commandline are repaced with variables. Sorry for that confusion.

Again, this a a very rare occurance, but has been reported a by a couple of users.

Ivan - Tracker Software
Site Admin
Posts: 3630
Joined: Thu Jul 08, 2004 10:36 pm
Location: Vancouver Island - Canada
Contact:

Re: Spooler SubSystem App Error on Driver Install

Post by Ivan - Tracker Software » Thu Jan 27, 2011 6:54 pm

I will make some investigation to find where problem might be, but without the way to reproduce problem it is not easy to fix it.
It is also possible that problem causes by other printer drivers/print processors installed in the system.
Tracker Software (Project Director)

When attaching files to any message - please ensure they are archived and posted as a .ZIP, .RAR or .7z format - or they will not be posted - thanks.

Post Reply