Page 1 of 1

Distribute the program

Posted: Thu May 26, 2005 1:30 pm
by kevinxgao1
I am able to run this exe file on my development PC. But, when I put it on a new PC, which has never installed any Track Software demo or SDK, it will not run. Could you help me to make this work? Attached is the files I want to distribute.

Yesterday I asked another question. I want to merge this piece of software into another program. Since I could not make it work, I just try to call it from our main application. I will still to try that later.

Thank you for your help.

Posted: Thu May 26, 2005 3:53 pm
by kevinxgao1
forgot mention: the new PCs and other test PCs have .NET framework installed. They are running our other .NET application correctly.

Posted: Thu May 26, 2005 4:05 pm
by John - Tracker Supp
Hi,

All looks complete (assuming you are installing these all to the same folder on the drive) - also if you are installing to W9x/ME Windows based systems you also need unicows.dll as detailed in the Help file IXCLib30Help.chm 'Redistribution of ...' topic.

Can you please be a little more expansive on the exact nature of the error message you get or do you not get one when you try and run ?

As much info as possible will help us to nail it down.

Thanks

Posted: Thu May 26, 2005 4:44 pm
by John - Tracker Supp
Just to follow up on this,

We have released several updates since the release you have and it may be some corrected items are affecting your distributoion - so can I suggest you download the latest build and if you still have problems send again (just your exe) and we will test here.

thanks

http://www.tracker-software.com/downloads/dev/

Posted: Tue May 31, 2005 8:01 pm
by kevinxgao1
Thank you very much for your help. I download the newest version as instructed and the result is the same. It is running perfectly fine on my own PC (ImageSDK package is installed). When I tried to put it on user's PC, it does not work. I tried two PCs and results are the same. Those two PCs have some other .Net applications installed and work fine.

You may try my previously attached files on a PC without Track Software installed.

Attached is the screenshot. Hope it helps.

Really appreciate your help.

Posted: Tue May 31, 2005 8:20 pm
by John - Tracker Supp
Hi

Can you advise what OS this is being installed on and also have you tried to run one of our own example applications just to see if that runs on this users equipment ok ?

thanks

Posted: Wed Jun 01, 2005 6:53 pm
by kevinxgao1
Sorry, forgot about this. I compiled the program on a Windows 2000 professional box with most recent patches. The user's PCs all have Windows XP with SP2 installed. This is our default settings.

Thank you for your help.

Posted: Wed Jun 01, 2005 7:06 pm
by kevinxgao1
I copied "C:\Program Files\Tracker Software\Image-XChange 3 SDK\bin" to their local drives (I did not do the isntall) from my workstation. "CSharpScanerDemo_ImgXChg.exe" is running. "CSharp_AxImages.exe" does not run with the same error messages.

Thank you very much for your help.

Posted: Thu Jun 02, 2005 8:58 am
by John - Tracker Supp
Hi Kevin,

Have you registered the ActiveX component on the machine in question using Regsvr32.exe ?

Any easy way to tell if this is the cause is to install the SDK directly which does this automatically as part of the installation.

Posted: Thu Jun 02, 2005 6:00 pm
by kevinxgao1
No, I did not register any of those ActiveX component. I will do them all as a test. It will be nice if you could tell me which dll is required to register, if not all of them.

If it works, I will put it in our documentation and included in a application installation routine.

Thank you very much.

Posted: Thu Jun 02, 2005 6:35 pm
by kevinxgao1
It works after regester "AxImages.dll". This is the only dll needs to be regestered. Thank you very much.

Posted: Thu Jun 02, 2005 6:42 pm
by John - Tracker Supp
Thanks Kevin,

pleased you got there ! ;)