XChange Lite 'Save Options' not working

This Forum is for the use of End Users requiring help and assistance for Tracker Software's PDF-XChange Printer Drivers only - Please do not post requests for older versions of PDF-XChange or the PDF-Tools/OFFice2PDF applications here

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan

Post Reply
hmw
User
Posts: 53
Joined: Wed Nov 30, 2011 12:26 am

XChange Lite 'Save Options' not working

Post by hmw » Sat Jun 09, 2018 5:18 pm

I have PDF-XChange 4.0 Lite, which came with my purchased copy of Editor. I run this on Windows 7 Pro (64 bit) SP1.

I have used this for years as my printing option to save documents as PDF files. It has always worked fine.

I recently decided that I wanted to have the file name, date, etc. included on the PDF that was created. So I accessed the Printing Preferences, clicked on Macro, and entered the codes that I wanted. See attached image.

As you can see, I have set the Path, File Name, Date & # of pages. Below the File Name: line, in Example:, it appears to show that the coding is correct. I then Save this. But when I select PDF-XChange 4.0 Lite as my printing option, the file is saved as a PDF, but none of the file name, date, etc. is included!

I know I saved the Options correctly, because when I go back to Printing Preferences, everything is still as I entered it. I even tried entering fewer macros, but the result was the same.

Any idea what the problem might be, or what I might be doing wrong?


Harry
Attachments
PDFLite_Printing PrefProblem.png

User avatar
Will - Tracker Supp
Site Admin
Posts: 6806
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: XChange Lite 'Save Options' not working

Post by Will - Tracker Supp » Sat Jun 09, 2018 8:24 pm

Hi Harry,

Thanks for the email - Please make sure that you're not setting these changes through e.g. the MS Word print dialog, as those changes will be remembered for that session of Word only. You'll need to change this via the Devices and Printers section of the Control Panel by right clicking the printer and selecting Printing Preferences.

Thanks,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

hmw
User
Posts: 53
Joined: Wed Nov 30, 2011 12:26 am

Re: XChange Lite 'Save Options' not working

Post by hmw » Sun Jun 10, 2018 12:23 am

Will - Tracker Supp wrote:Hi Harry,

Thanks for the email - Please make sure that you're not setting these changes through e.g. the MS Word print dialog, as those changes will be remembered for that session of Word only. You'll need to change this via the Devices and Printers section of the Control Panel by right clicking the printer and selecting Printing Preferences.

Thanks,
Will:

I did set this through Devices and Printers. Sorry I was not clear on that.

And each time I return there, what I entered is still there. So what I added is not being deleted.


Harry

Willy Van Nuffel
User
Posts: 1387
Joined: Wed Jan 18, 2006 12:10 pm

Re: XChange Lite 'Save Options' not working

Post by Willy Van Nuffel » Sun Jun 10, 2018 7:30 am

The problem with the naming of the resulting PDF-files (via the "File Name" text box in Printer Properties > Settings > Save) in the PDF-XChange printers is still present today. Tracker Software Support answered me that their developers are working on it:
viewtopic.php?f=39&t=30505&p=123361

What you can try, is add ".PDF" at the end of the naming string.

Something like this:

%[DocPath]_%[DocName]_%[Date]_%[Pages].pdf

Currently, I can not immediately test this for you, to verify what it gives with the PDF-XChange 4.0 Lite printer.
At this moment, I have only the PDF-XChange Standard printer (V7 - build 325.1) installed.
And, I also do not know if it currently works correctly with the PDF-XChange Lite V7 version.

hmw
User
Posts: 53
Joined: Wed Nov 30, 2011 12:26 am

Re: XChange Lite 'Save Options' not working

Post by hmw » Sun Jun 10, 2018 7:36 pm

Willy:

Adding the extra .pdf to the end of the filing string did NOT help.

However, I went here: viewtopic.php?f=39&t=30505&p=123361 and read everything there

I did a lot of testing, and I found the only culprit was the [Date] macro. Checking both 'Show Save As' and 'Run Application after Printing' works. Attached is a screen print of my settings. I make all the changes in Settings->Control Panel->Devices and Printers.

I will also post this at the above URL that you sent me to. so Tracker Support does not think you are the only person complaining.


Harry
Attachments
PDF-Exchange Lite_PrintingPreferences.png

User avatar
Will - Tracker Supp
Site Admin
Posts: 6806
Joined: Mon Oct 15, 2012 9:21 pm
Location: London, UK
Contact:

Re: XChange Lite 'Save Options' not working

Post by Will - Tracker Supp » Mon Jun 11, 2018 7:23 am

Thanks Willy - I wasn't aware of that. As I've mentioned in a previous thread, I'm freshly back at Tracker after almost a year away, so I'm still catching up on everything; including known issues.

For now, seeing as this is a known issue and seeing as Harry has now also posted in the other thread, I think it best if we keep the discussion around this issue there, so it is in one place.

Cheers,
If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.
Thank you.

Best regards

Will Travaglini
Tracker Support (Europe)
Tracker Software Products Ltd.
http://www.tracker-software.com

Post Reply