Found an error if computer running XP, works in Vista and W7

PDF-XChange Viewer SDK for Developer's
(ActiveX and Simple DLL Versions)

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
magthenop
User
Posts: 43
Joined: Tue Sep 07, 2010 8:35 am

Found an error if computer running XP, works in Vista and W7

Post by magthenop » Wed Dec 01, 2010 8:02 am

If I have all the Comments Contracted and Selects an Polygon (or creates an Pylygon, Polyline etc) in the pdf on all platforms I have tested except XP the comment expands and shows this in he commats panel, I would like it to behave the same on a XP machine.

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13626
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Found an error if computer running XP, works in Vista and W7

Post by Tracker Supp-Stefan » Wed Dec 01, 2010 10:58 am

Hello magthenop,

Using the stand alone Viewer I can confirm that on an XP machine it does expand the correct category of comments as soon as you finish the polygon shape, or select an existing one - with build 2.5.188 that is.

Is the behaviour different through your application?

Best,
Stefan

magthenop
User
Posts: 43
Joined: Tue Sep 07, 2010 8:35 am

Re: Found an error if computer running XP, works in Vista and W7

Post by magthenop » Wed Dec 01, 2010 11:51 am

It is when using the PDF-XChange Viewer SDK in our application that this behaviour shows (do not know if it works when the customer uses the stand alone app), I am using the 2.5.188 version.
I have the comments panel visible and sorted by author, before the user either selects an allready existing measurement or makes a new one all comments are contracted. This worked when I was using ver 2.0.57 in my project.

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13626
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Found an error if computer running XP, works in Vista and W7

Post by Tracker Supp-Stefan » Wed Dec 01, 2010 12:33 pm

Hello magthenop,

I did chereate a ticket in our internal system:
#646: Viewer SDK build 2.5.188 incorrect comments behaviour under XP
So the dev guys could check this and advise.

Will keep you updated here in the topic.

Best,
Stefan

magthenop
User
Posts: 43
Joined: Tue Sep 07, 2010 8:35 am

Re: Found an error if computer running XP, works in Vista and W7

Post by magthenop » Wed Dec 01, 2010 1:21 pm

Thank´s Stefan :D

Corwin - Tracker Sup
User
Posts: 670
Joined: Tue Nov 14, 2006 12:23 pm

Re: Found an error if computer running XP, works in Vista and W7

Post by Corwin - Tracker Sup » Wed Dec 01, 2010 5:21 pm

Hi magthenop,

I have tested this on my Win XP with latest viewer SDK and doesn't find any problem with this. One more question: can you reproduce such behavior with Viewer SDK example projects? If so, then please write step-by-step instruction of how this can be reproduced.

Thanks.

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13626
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Found an error if computer running XP, works in Vista and W7

Post by Tracker Supp-Stefan » Mon Dec 13, 2010 10:35 am

Hello magthenop,

We have not heard from you on this case for almost two weeks, so shall we consider this one as resolved?

Best,
Stefan

Post Reply