Unchecking "Display PDF in Browser" does not work in ver 2.5

The PDF-XChange Viewer for End Users
+++ FREE +++

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Paul - Tracker Supp, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
MLasby
User
Posts: 8
Joined: Sat Dec 18, 2010 4:58 pm

Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by MLasby » Sat Dec 18, 2010 5:18 pm

I recently upgraded from PDF-Xchange Viewer Pro ver 2.0.54 to ver 2.5.189. I am using Firefox 3.6.13 and Windows XP Pro SP3.
In ver 2.0 I unchecked the box in front of "Display PDF in Browser" and when I clicked on a link to a PDF file I was asked if I wanted to save the file or open it in PDF-Xchange Viewer. If I check this box the PDF file would open in the Firefox window.
In ver 2.5 it does not matter if the box is checked or not. When I click on a link to a PDF file it always opens in Firefox.
In ver 2.5 the check box has the correct influence on Windows Internet Explorer.
I am going back to ver 2.0 until you tell me that this has been fixed.

User avatar
Bhikkhu Pesala
User
Posts: 1772
Joined: Tue May 29, 2007 9:29 am
Location: East London
Contact:

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by Bhikkhu Pesala » Sat Dec 18, 2010 8:52 pm

Fix it yourself

Tell Firefox to open PDF files in the external application, instead of using the plugin.
Windows 10 64-bit • AMD A10-6800K, 8 Gbyte RAM
Review: http://www.softerviews.org/PDF-XChange.html

MLasby
User
Posts: 8
Joined: Sat Dec 18, 2010 4:58 pm

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by MLasby » Sat Dec 18, 2010 9:24 pm

Bhikkhu Pesala wrote:Fix it yourself
Where is that setting in the Firefox Options?

User avatar
Bhikkhu Pesala
User
Posts: 1772
Joined: Tue May 29, 2007 9:29 am
Location: East London
Contact:

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by Bhikkhu Pesala » Sat Dec 18, 2010 10:18 pm

I use the plugin for Opera, so I never open PDF files in Firefox.

In Firefox go to Tools, Options, Applications, and chose PDF-XChange there for the PDF file type. I presume it is currently set to use the plugin in your case.
Windows 10 64-bit • AMD A10-6800K, 8 Gbyte RAM
Review: http://www.softerviews.org/PDF-XChange.html

MLasby
User
Posts: 8
Joined: Sat Dec 18, 2010 4:58 pm

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by MLasby » Sat Dec 18, 2010 10:26 pm

In my setup of Firefox both FDF and PDF are set to "Always ask".

Chris - Tracker Supp
User
Posts: 797
Joined: Tue Apr 14, 2009 11:33 pm

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by Chris - Tracker Supp » Sun Dec 19, 2010 4:16 pm

Hi MLasby,

Please let us know your operating system, whether it is 32 or 64 bit, and the verison of Firefox you are using so we can recreate the issue.

Thanks,
Chris
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.


Chris Attrell
Tracker Sales & Support North America
http://www.tracker-software.com

MLasby
User
Posts: 8
Joined: Sat Dec 18, 2010 4:58 pm

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by MLasby » Sun Dec 19, 2010 4:30 pm

MLasby wrote:I am using Firefox 3.6.13 and Windows XP Pro SP3.
My laptop is a 4 year old Lenovo T60 so I assume it is 32 bit.

Chris - Tracker Supp
User
Posts: 797
Joined: Tue Apr 14, 2009 11:33 pm

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by Chris - Tracker Supp » Sun Dec 19, 2010 4:34 pm

Thanks,

We'll investigate and get back to you shortly on the matter.

Best,
Chris
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.


Chris Attrell
Tracker Sales & Support North America
http://www.tracker-software.com

Katya - Tracker Supp
User
Posts: 39
Joined: Tue Apr 20, 2010 10:48 pm

Re: Unchecking "Display PDF in Browser" does not work in ver 2.5

Post by Katya - Tracker Supp » Mon Dec 20, 2010 11:52 am

Hi MLasby,

I've consulted with the dev team:
it looks like it is NOT our problem, it seems like it's the issue with Firefox (3.6.13)

But we found a workaround for this issue:
1. Close browser
2. Run Standalone Viewer and uncheck 'Display PDF in browser', press OK and close application
3. Run Firefox and go to 'Menu/Tools/Options/Applications' and set 'Save file' value for 'Adobe Acrobat PDF (application/pdf)' item and press OK. Close Firefox.
4. Run browser again - and go to 'Menu/Tools/Options/Applications' and set 'Always Ask' value for 'Adobe Acrobat PDF (application/pdf)' item and press OK.

After these 'magic' manipulations Firefox will understand correctly the meaning of 'Always Ask' value for 'Adobe Acrobat PDF (application/pdf)' item. :wink:

HTH

P.S. We reproduced the same problem on PC where only Acrobat Reader was installed (without PDF-XChange Viewer) - and we 'resolved' the issue in the same way.

Post Reply