[Bug] Problems with special characters { [ ] } \ ~ |

The PDF-XChange Viewer for End Users
+++ FREE +++

Moderators: TrackerSupp-Daniel, Tracker Support, Paul - Tracker Supp, Vasyl-Tracker Dev Team, Chris - Tracker Supp, Sean - Tracker, Tracker Supp-Stefan, Ivan - Tracker Software

Post Reply
chris83
User
Posts: 3
Joined: Tue Dec 18, 2007 10:41 am

[Bug] Problems with special characters { [ ] } \ ~ |

Post by chris83 » Tue Dec 18, 2007 10:56 am

Hello,
I can not print the following characters:
{ } [ ] \ | ~

I am using a German keyboard layout, and the German version (1.0 Build 0030) of the PDF XChange Viewer.

On a German keyboard I get this characters by typing ALT+7 and so on.

I am using this characters a lot. Is there another way to write this characters?

Thanks
Chris

User avatar
Bhikkhu Pesala
User
Posts: 1776
Joined: Tue May 29, 2007 9:29 am
Location: East London
Contact:

Post by Bhikkhu Pesala » Tue Dec 18, 2007 12:56 pm

Check out this thread. Same problem. AltGr shortcuts don't work yet. Will be fixed some time.

A workaround is to type in Wordpad, or elsewhere, and paste text into the text edit box. Otherwise, try the US International keyboard, which uses dead keys for typing accents " + u = ü etc. Dead keys work OK in PDF-XChange.
Windows 10 Home 64-bit • AMD Ryzen 5 3400G, 8 Gb
Review: http://www.softerviews.org/PDF-XChange.html

chris83
User
Posts: 3
Joined: Tue Dec 18, 2007 10:41 am

Post by chris83 » Tue Dec 18, 2007 1:42 pm

Thanks for comming back on this topic so fast.
I used the workaround already, but as an informatic student who needs the "{}" characters as offen as a "." character, it is not really usefull!

I used Foxit Reader before and it is working there since some months. It is free to use, too, but they print some advertisement if I save the changed file.

It seems like I have to wait on this for the next version of PDF XChange Viewer, and use it only to delete the stamps Foxit Reader puts into my files.

If it works, I will switch to XChange - it seems to be a great product.
Thanks
Chris

User avatar
John - Tracker Supp
Site Admin
Posts: 5213
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Tue Dec 18, 2007 2:55 pm

Hi,

We are hoping this will be resolved in build 31 - due quite soon now.

HTH
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

chris83
User
Posts: 3
Joined: Tue Dec 18, 2007 10:41 am

Post by chris83 » Fri Jan 04, 2008 11:34 am

Hey
I downloaded build 31 some days ago and it seems that the issue with the special characters is not solved. Is there a task to solve it in build 32? How long do we have to wait for this build?

Thanks
Chris

User avatar
John - Tracker Supp
Site Admin
Posts: 5213
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Fri Jan 04, 2008 1:28 pm

Apologies will be in Build 32 for sure and this is due next week.

Thanks for your patience.
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

MedBooster
User
Posts: 12
Joined: Mon Nov 15, 2021 8:38 pm

Re: [Bug] Problems with special characters { [ ] } \ ~ |

Post by MedBooster » Sat Dec 18, 2021 5:37 pm

I'm experiencing something similar in PDF-xchange editor (it seemed to not be a problem in PDF-xchange viewer
image.png
I have alt + A set as a shortcut to activate the arrow tool, and I have AltGr (ctrl+alt) set to a character (keyboard shortcut – "α". When I press ctrl+alt+a it activates "α", but when I press altGr it seems to just function as alt instead of Ctrl+Alt. it is also important to mention that I think it is very important that if a shortcut in the program interferes with a keyboard shortcut if you are in a field (meaning you can type something) AltGr activates the character keyboard shortcut, and Ctrl + Alt activates the program keyboard shortcut :D

User avatar
TrackerSupp-Daniel
Site Admin
Posts: 5371
Joined: Wed Jan 03, 2018 6:52 pm

Re: [Bug] Problems with special characters { [ ] } \ ~ |

Post by TrackerSupp-Daniel » Mon Dec 20, 2021 5:04 pm

Hello, MedBooster

Thank you for the report, The updater itself gets updates less frequently than most of our products, so its version number is not particularly indicative of what is running on your PC. Could I ask you to please first update to the latest version (9.0.359.0) and confirm for me if the same issue is present there on your device? You can check the version of our installed Editor by clicking "help > about" at any time there.

Kind regards,
Daniel McIntyre
Support Technician
Tracker Software Products (Canada) LTD

Support: <Support@tracker-software.com>
Sales: +1 (250) 324-1621
Fax: +1 (250) 324-1623

MedBooster
User
Posts: 12
Joined: Mon Nov 15, 2021 8:38 pm

Re: [Bug] Problems with special characters { [ ] } \ ~ |

Post by MedBooster » Thu Dec 23, 2021 12:49 pm

I am now using pdf editor plus v9.2.357.0 and the problem seems to persist there. The problem is that the keyboard shortcut (for character input) is not prioritized when in a typing field (most apps I am using XMind, Notion, Anki etc. are handling this fine (and PDF xchange viewer seemed to also handle this fine. If you contact me I'd be happy to make a descriptive video or something if you still don't see what I mean.

MedBooster
User
Posts: 12
Joined: Mon Nov 15, 2021 8:38 pm

Re: [Bug] Problems with special characters { [ ] } \ ~ |

Post by MedBooster » Thu Dec 23, 2021 1:21 pm

I did some more research and as it turns out pdf xchange editor plus doesn't even recognize AltGr as ctrl+alt, it simply recognizes it as alt, see the attached screenshot
image.png
image1.png

User avatar
Dimitar - Tracker Supp
Site Admin
Posts: 1089
Joined: Mon Jan 15, 2018 9:01 am

Re: [Bug] Problems with special characters { [ ] } \ ~ |

Post by Dimitar - Tracker Supp » Thu Dec 23, 2021 1:24 pm

Hello MedBooster,

We will appreciate it if you could create a short video that indicates the problem you are facing.

Please send it to: support@tracker-software.com

Before you proceed, please update your product to the latest version 9.2.359.0:

https://www.tracker-software.com/product/downloads

Regards.

Post Reply