Page 1 of 1

Problem with xcp2t30 in v3.6.0.104

Posted: Thu Aug 10, 2006 9:11 pm
by scanstore
I had recently downloaded and installed the latest versions of the PDF-XChange SDK and when running my application and the PDF2Text sample I get:

File not found: xcp2t30

I found this odd since my distributed application doesn't have this problem. I checked the dependencies for xcp2t30.dll and found that xcpars30.dll was required but not installed with the latest PDF-Xchange download. Also, one of the functions in dscrt30.dll used by xcpars30.dll was missing, so adding xcpars30.dll back to the folder didn't work either.

When I reverted all versions of the xcpro dlls back to 3.5.0.95 everything works great. The version for xcp2t30.dll was 3.5.0.88 in both cases.

I tried this on a clean machine and got the same results.

Posted: Thu Aug 10, 2006 10:31 pm
by John - Tracker Supp
Hi,

Some time ago xcpro30.dll was replaced by xcpro35 and this also now contains all text extraction functionality - xcp2t30.dll and xcpars30.dll are now redundant and no longer required.

Please see the demo app's available and also the xcpro35.chm help file for more detailed info.

Should you have any specific questions please do come back.

HTH

Posted: Fri Aug 11, 2006 12:11 am
by scanstore
I have to say it would've been much more obvious that this was the case if there was not a PDF2Text EXE, sample projects and help file still contained in the installer, all of which still refer to the old pdf2text dll.

Posted: Fri Aug 11, 2006 10:24 am
by John - Tracker Supp
Hi,

Yes - no defence - I agree with you 100%, I have asked for this to be done asap.

Thanks for your patience.