Image Extraction - Only "Top Half" of Image Extrac

This Forum is for the use of Software Developers requiring help and assistance for Tracker Software's PDF-Tools SDK of Library DLL functions(only) - Please use the PDF-XChange Drivers API SDK Forum for assistance with all PDF Print Driver related topics.

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software, Andrew - Tracker Support, Tracker - Clarion Support, John - Tracker Supp, Support Staff, moderators

Post Reply
neilpitman
User
Posts: 39
Joined: Fri Jun 17, 2005 8:38 am

Image Extraction - Only "Top Half" of Image Extrac

Post by neilpitman » Fri Jul 29, 2005 3:06 pm

Attempting to extract an image with PDFXCp_SaveImageFromPage etc from the attached sample PDF results in an image file which appears to be just the "top half" of the image. This is true using the SDK examples (saveimagesfrompdf, imagefrompdf) or our own app.

Any workaround would be appreciated.

Thanks
Attachments
sample.zip
Sample PDF with Images
(314.95 KiB) Downloaded 136 times

John - Tracker Supp
Site Admin
Posts: 8205
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed Aug 03, 2005 11:56 am

Hi Neil,

this is replicated here - looking into the cause now - not sure if the issue is ours or a problem in the PDF formatting itself - will advise as soon as we have more info or a fix.

thanks
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

John - Tracker Supp
Site Admin
Posts: 8205
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Thu Aug 04, 2005 7:29 am

Hi Neil,

Issue is resolved and will be released in Build 88 released next week.
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

neilpitman
User
Posts: 39
Joined: Fri Jun 17, 2005 8:38 am

News on Build 88?

Post by neilpitman » Wed Aug 24, 2005 6:00 am

Any news on when build 88 will be available? We really need the fix ASAP.

Thanks

John - Tracker Supp
Site Admin
Posts: 8205
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed Aug 24, 2005 10:14 am

Hi,

we were hoping to release with the inclusion of 'Form Fields' - but it looks like this is too complex to realise in time for form fields support in build 3.5088 so will be delayed for later release.

In view of this - build 3.5088 should be released during next week - but I canot be more specific as this is still a major update with several major new features and the inclusion of the new 64 bit XP/Vista drivers.
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

neilpitman
User
Posts: 39
Joined: Fri Jun 17, 2005 8:38 am

Another Example

Post by neilpitman » Thu Aug 25, 2005 8:56 am

Attached is another test file from a totally different source that also exhibits the "top half of an image" problem - would it be possible to confirm that the fix will also work for this file.

Thank You.
Attachments
sample2.zip
(127.57 KiB) Downloaded 139 times

John - Tracker Supp
Site Admin
Posts: 8205
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Thu Aug 25, 2005 9:44 am

Hi Neil,

I can confirm this file appears correct in the new build 88 test version here.
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

neilpitman
User
Posts: 39
Joined: Fri Jun 17, 2005 8:38 am

Post by neilpitman » Wed Oct 05, 2005 8:01 am

Build 88 fixed the problem for the original file but we have found another example which appears to exhibit the same problem.

We have now also purchased Image-X Change but the problem still occurs on this new example even using PXCp_GetDocImageAsXCPage and IMG_ImageSaveToFile instead of PXCp_SaveDocImageIntoFileW.

The attched archive shows the original PDF and the generated TIFF.

Is there some possible work-around or fix? We're keen to get a solution for the end user asap. We are using 3.5091.

Thanks
Attachments
newexample.zip
(632.63 KiB) Downloaded 142 times

John - Tracker Supp
Site Admin
Posts: 8205
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed Oct 05, 2005 9:44 am

Neil,

can you please check build 91 and advise if this resolves the issue ?

Thanks
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

neilpitman
User
Posts: 39
Joined: Fri Jun 17, 2005 8:38 am

Post by neilpitman » Wed Oct 05, 2005 9:58 am

We are using build 91 and the problem occurs with the new example just posted although the previously posted example works fine in 91.

John - Tracker Supp
Site Admin
Posts: 8205
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed Oct 05, 2005 11:11 am

Neil,

the results you see are correct - there are 10 separate images in this file - not 5, hence you have 10 images extracted.
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

Post Reply