Font not appearing in pdf (but is in the wmf) issue

This Forum is for the use of Clarion For Windows - Software Developers requiring help and assistance for Tracker Software's PDF-Tools SDK of Library DLL functions(only) - Please use the PDF-XChange Drivers API SDK Forum for assistance with all PDF Print Driver related topics.

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software, Tracker - Clarion Support, John - Tracker Supp, Support Staff, moderators

Post Reply
StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Font not appearing in pdf (but is in the wmf) issue

Post by StuAndrews » Tue May 17, 2016 6:31 am

Hi Tracker and Clarion Folk,

Attached is a zip file containing both a wmf and a pdf file of the same report.

There's a big "FOR SALE" piece of text in the middle of the report.

In the WMF, the text appears in the font I want (it's called "HelveticaNeue MediumCond" in the clarion report interface, but is something else in the windows font file section).

But the PDF, it reversed back to .. default? Not sure, but is obviously not the same font.

Any ideas what I might be able to do to sort this out?

Cheers.

Edit #1

I'm wondering if this might be the size? of the font related. It's 140 in the clarion report interface.

Perhaps not though. When I change the font from the helvetica to "Arial Narrow", it embeds into the pdf fine.

Edit #2

Strange. On a much smaller piece of text in the report, when I change that to "HelveticaNeue MediumCond", it shows that font in the pdf (BUT the font itself is not embedded in the pdf when I check the fonts tab of the pdf details) for that small piece of text.

HOWEVER, even though that small piece of text, small font size, shows the font I want in the bigger piece of text, it still doesn't recognise that the font exists for the big "FOR SALE" piece of text.

Very wierd.
Attachments
FontMissingIssue_2016.05.17.zip
(1.14 MiB) Downloaded 94 times
---
Cheers,

Stu Andrews
http://stuandrews.com

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13530
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Font not appearing in pdf (but is in the wmf) issue

Post by Tracker Supp-Stefan » Tue May 17, 2016 9:55 am

Hello Stu,

The size should not matter - text is rendered from vector objects :)

The font does not seem to be embedded in the PDF File (it is not embedded in the wmf either - as on my machine I see the font incorrectly displayed from both files), so you will need to make sure that when you generate the file - you embed all used fonts to ensure the file displays OK even on machines where the font is not installed/present.

Regards,
Stefan

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font not appearing in pdf (but is in the wmf) issue

Post by StuAndrews » Wed May 18, 2016 2:08 am

Hi Stefan,

Apologies, I didn't make it clear in the original post.

Embedding the fonts manually doesn't make any difference.

1. The pdf has the TradeGothic fonts embedded, but that's not me, it's done automatically. So why not Helvetica?
2. When I add the Helvetica fonts manually into the pdftools template interface, they are not embedded into the pdf.
3. The Helvetica font shows when used with one of the smaller pieces of text on the pdf.
---
Cheers,

Stu Andrews
http://stuandrews.com

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13530
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Font not appearing in pdf (but is in the wmf) issue

Post by Tracker Supp-Stefan » Wed May 18, 2016 10:11 am

Hello StuAndrews,

I spoke with a colleague that worked on the Tools SDK (not a clarion developer himself) and he asked for a more detailed explanation of how exactly is the PDF file created (e.g. which methods are used).
He also said that going through a metafile is not recommended if you have direct access to the API, and can generate the file yourself - as this will avoid getting information lost/changed during the metafile creation, or when converting from the metafile to PDF.
I will now also ask our Clarion developer to take a look at this and advise, as there might be a slightly different solution for Clarion.

Regards,
Stefan

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font not appearing in pdf (but is in the wmf) issue

Post by StuAndrews » Thu May 19, 2016 10:14 pm

Hi Stefan,

The pdf is created using the pdf-tools template on a report.

The only custom information in the template is the size (it's custom, and I set it manually in the template), along with the font embedding.

The system is a nettalk webserver. The report is generated from the user end by a start button + progress bar interface, and the user clicks on the resulting link which opens the pdf.

I use this throughout the system in many different places for many different reports. They all work okay.

This particular report is having issues with the font.

It might not be anything related, but what seems confusing to me is that what the Helvetica fonts are called in the windows font folder are not what they are called in the clarion reporting interface.

IE - I installed the fonts, years ago, through the windows font installation mechanism. They're there, I can see them. Cool.

In the clarion report interface, I can see the Helvetica fonts, but most of them have different names. I'm not sure if this is because clarion looks at different information for the font or what.

And it might not have anything to do with this, but thought I'd include it just in case.

** Note: I use the WMF because that's what you guys have always said is the first step to debugging any issues like this with pdf generation. See what the clarion report engine generates, as opposed to what's in the pdf, because then you can rule out the clarion report generator (to whatever degree).

Look forward to hearing what your clarion developer says.
---
Cheers,

Stu Andrews
http://stuandrews.com

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Re: Font not appearing in pdf (but is in the wmf) issue

Post by John - Tracker Supp » Tue May 24, 2016 7:26 am

Hi Stu,

This looks like a case where the Helvetica font is either not complete, available or just not there and as Arial is a default font of the PDF format and natively supported (no embedding required) it will be used as the defacto substitute.

Can you please zip up the Helvetica fonts you have and supply them - either here in a zip archive or by email and with a link back to this forum thread as a reference and we will take a look.

Can you please send by email to support@tracker-software.com and make for the attention of 'John & Ivan'

Thanks
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

Post Reply

Return to “PDF-Tools SDK (DLL Libraries Only) - Clarion For Windows Developers Only Please”