Page 1 of 1

Issue with Clarion10 installer

Posted: Mon May 18, 2015 5:31 am
by dsbglobal
Hi Craig
I installed the latest pdf tools sdk onto a new clarion 10 enterprise install.

When compiling the first example I get an entry point not found ... error in xcpro.dll.

I checked on my computer, and the Clarion 10 version of this file is date 9/2/15 (790616 bytes) while the Clarion 9 version is dated 1/8/14 and is 747072 bytes.

If I copy the "old" dlls into the app folder, it runs fine.

Could there be an issue with your installer installing the wrong dlls ?

cheers
Dave Beggs

Re: Issue with Clarion10 installer

Posted: Mon May 18, 2015 2:31 pm
by Tracker - Clarion Support
Hi Dave!

I just tried it here and all seems correct, so I need more information from you. We only have one installation version, so referring to it as "Clarion 9" and "Clarion 10" only tells me where you installed it, not which version of our software you installed.
When compiling the first example I get an entry point not found ... error in xcpro.dll.
I need to see a screen shot of the exact message you received.
I checked on my computer, and the Clarion 10 version of this file is date 9/2/15 (790616 bytes) while the Clarion 9 version is dated 1/8/14 and is 747072 bytes.
That only means you haven't updated your PDF-Tools in your Clarion 9 installation, nothing more. You can check the actual file version, which would be helpful, by looking at your Clarion10\accessory\bin folder in FE with the File Version active. That will give you the actual file versions installed and that could be useful.
If I copy the "old" dlls into the app folder, it runs fine.
NOT recommended, as the class and template files might not match the older dll versions.

I would erase all the dll's from your app folder, rebuild the app, and see if the problem returns. If it does you will need to check the dll File Versions and make sure that all are the same, except for ocrtools.dll which uses a different numbering scheme.

Please take a screen shot of the FE page showing all the copied dll's and post it here so I can check it.