Font / Permissions Issue? (WMF shows text, PDF doesn't)

This Forum is for the use of Clarion For Windows - Software Developers requiring help and assistance for Tracker Software's PDF-Tools SDK of Library DLL functions(only) - Please use the PDF-XChange Drivers API SDK Forum for assistance with all PDF Print Driver related topics.

Moderators: TrackerSupp-Daniel, Tracker Support, Vasyl-Tracker Dev Team, Sean - Tracker, Chris - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software, Tracker - Clarion Support, John - Tracker Supp, Support Staff, moderators

Post Reply
StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Wed Aug 07, 2013 1:16 pm

Hi Folks (Craig, hey there!),

Before I go too far into this, just wanting to see if these two images spark any "quick fix" ideas.

I'm generating a pdf with overlay.

The first image shows a portion of the WMF file.

The second image shows that portion of the PDF.
Images WMF and PDF.zip
(42.18 KiB) Downloaded 193 times
The only text that seems to get through are NUMBERS.

Any initial thoughts?
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Wed Aug 07, 2013 1:23 pm

Hi Stu!

None, I'm afraid.

Please email me your WMF and Overlay PDF files.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Wed Aug 07, 2013 10:24 pm

Doing so now.
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Wed Aug 07, 2013 10:40 pm

Hi Stu!

I have the files - thanks!

I'll have to pick this one up in the morning. I'm generating unexpected template errors in the Images to PDF template that I need to check out your problem.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 5:51 am

Just wanted to put this up so that it's in this information store.

--

1. Nettalk websystem was running fine on 2003 windows server.

2. Installed on 2008 windows server, this issue (and one other) with pdfs appeared.

3. Is NOT, as far as I can tell, the "start service as another user account that can see the printer" issue (that's already in place and working great).

4. Happens whether running as a service OR as an exe.

--

More stuff:

* This is only on the live (new) 2008 server. Can't replicate on dev machine (running as exe or service).
* This doesn't happen on the 2003 windows server.

From old emails I can see that this problem occurred back in 2011, BUT there is no record how it got solved. And it did get solved, because we ran since that time on the 2003 windows server with it working fine.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 6:34 am

Further investigation:

The reports that don't use an overlay are working fine (categorically, all reports without overlay work, all with do not).

Makes me lean more towards a permissions issue.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 12:21 pm

Hey Craig, any word on this?

(Am sweating on it, three days without live being able to print out advertising brochures and signboards)
---
Cheers,

Stu Andrews
http://stuandrews.com

User avatar
Tracker Supp-Stefan
Site Admin
Posts: 13544
Joined: Mon Jan 12, 2009 8:07 am
Location: London
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker Supp-Stefan » Thu Aug 08, 2013 12:38 pm

Hello Stu,

Craig is in our US office and it's currently 8:38 AM where he is. He should be able to reply to you shortly.

Regards,
Stefan

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 12:42 pm

Wonderful, thank you Stefan!

I'm here all night :) -- my night that is.
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Thu Aug 08, 2013 1:07 pm

Hi Stu!

I'm working on a small app to demonstrate the problem. I should have results later today.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 1:13 pm

Okay, thanks for the update.

Can you give me an estimate no hours? It's 11pm here, want to know if I stay up.

Also -- Have you got any kind of hints as to what might be the problem? Something I can get working on this end right away?
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Thu Aug 08, 2013 1:16 pm

Hi Stu!

My suggestion is go to bed and look for an email first thing when you get up.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 1:32 pm

Thanks Craig, will get some sleep.

Let me know how you go, this is really becoming mission-critical for me.

What's really busting me up is that we had this happen when we first put the system in (2011, on the win 2003 server), and obviously we solved it .. But I can't find any solution for this specific issue!

Anyway, may you find out what's going on!
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Thu Aug 08, 2013 4:57 pm

Hi Stu!

I just emailed you the output PDF and app file for the test run - it seems to have worked fine here.

I'm afraid I don't really have an answer to your problem. The only thought that occurs is to use embedded fonts, if your fonts are not the standard ones.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 11:05 pm

Nooooooooooo.

I really needed even just a hint of what _might_ be happening.

It's linked to the Overlays.

Was working on Monday on the old win 2003 server.

Installed and running on new win 2008 server, doesn't work.

I have no idea, completely no idea, what to do to test or otherwise.
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Thu Aug 08, 2013 11:45 pm

Hi Stu!

I'll escalate this upstairs to the Project Manager, and see what he says.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Thu Aug 08, 2013 11:53 pm

Thanks Craig, appreciate it.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 12:16 am

Check the difference between the screenshot of the WMF and how the WMF opens up on your machine.

Just been reading, and WMFs (as you probably know, I didn't!) only contain references to fonts.

So on the win 2008 server, the wmf looks strange (numbers are much larger that letters). When I open on my dev machine, it looks okay.

I'm investigating down this line at the moment.
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Fri Aug 09, 2013 12:57 am

Hi Stu!

Did I mention possibly embedding fonts in the output PDF?
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 1:00 am

Hi Craig,

"Enabled Font Embedding" is already ticked.

Do I need to do anything more than that?
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Fri Aug 09, 2013 1:21 am

Hi Stu!

Add whatever strange fonts you are using to the Fonts to Embed button.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 1:29 am

That's just it.

Arial.

What is strange about Arial?

The overlay does use some, but the report does not. So would the fonts in the overlay be affected?
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 2:50 am

Embedding specifically didn't solve the issue.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 3:23 am

Okay, different angle question.

1. A report has a string field.
2. That string field has both numbers and letters in it.
3. The font is "Arial".
4. The WMF prints both the numbers and the letters, but the numbers are ~twice the fontsize as the letters.
5. The PDF prints ONLY the numbers.
6. Only happens when an Overlay is used.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 7:27 am

* Also, the system has gone from a 32 bit server to a 64 bit server.

Not sure if that will make a difference with the PDFTools stuff.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 7:40 am

Craig - I wonder if the embedding didn't do anything because I'm not putting the "Names" in correctly.

Basically just used the strings according to what Adobe Reader told me were the fonts, eg:

Helvetica
HelveticaNeue-Light
Neutraface-Display

That kind of thing.
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 8:09 am

Can confirm that when embedding the fonts in the global PDFTools template they do not appear in the pdfs generated (checking by opening the pdf in adobe reader, going to properties, checking the font list).
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Fri Aug 09, 2013 11:16 am

Following on with the embedding conversation:

Why would I need to embed fonts in reports with overlays when reports without overlays use custom fonts and don't have them embedded?
---
Cheers,

Stu Andrews
http://stuandrews.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Sat Aug 10, 2013 1:28 am

Hi Craig,

Any word (answer, hint, partial, whatever :) ) on my queries above?
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Mon Aug 12, 2013 1:59 pm

Hi Stu!

I'm sorry I went silent there for a bit. I've been having some internet issues since the ISP replaced our cable router last week, and apparently missed your later inquiries.

I've sent your problem off to our Project Manager, as it seems to be inside the libraries themselves. I did that Friday so we should hear from him today.

Later: No we won't hear from him before week's end - he's off on vacation! :o
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

StuAndrews
User
Posts: 62
Joined: Wed Jul 14, 2010 11:46 pm

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by StuAndrews » Mon Aug 12, 2013 4:34 pm

Hey Craig,

Thanks for the info.

I actually worked around the situation.

Basically it was the ARIAL font giving me grief. So I changed the font to MS SANS SERIF and the problem went away.

I don't know why it happens with Overlays and doesn't without Overlays. But there you go.
---
Cheers,

Stu Andrews
http://stuandrews.com

Tracker - Clarion Support
Site Admin
Posts: 1412
Joined: Wed Jun 30, 2004 4:45 pm
Location: Maryland, USA
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Tracker - Clarion Support » Mon Aug 12, 2013 4:43 pm

Hi Stu!

That's good information - thanks! I'll pass that along to the Project Manager when he returns.
Craig Ransom
Tracker Software - Clarion Support
http://www.tracker-software.com

Ivan - Tracker Software
Site Admin
Posts: 3609
Joined: Thu Jul 08, 2004 10:36 pm
Location: Vancouver Island - Canada
Contact:

Re: Font / Permissions Issue? (WMF shows text, PDF doesn't)

Post by Ivan - Tracker Software » Fri Aug 16, 2013 2:29 pm

Can you send me WMF file and generated PDF file where the problem is ? (I mean with Arial font)
Tracker Software (Project Director)

When attaching files to any message - please ensure they are archived and posted as a .ZIP, .RAR or .7z format - or they will not be posted - thanks.

Post Reply

Return to “PDF-Tools SDK (DLL Libraries Only) - Clarion For Windows Developers Only Please”