Pxc30Com Error

This Forum is for the use of Software Developers requiring help and assistance for Tracker Software's PDF-XChange Printer Drivers SDK (only) - Please use the PDF-Tools SDK Forum for Library DLL assistance.

Moderators: Tracker Support, TrackerSupp-Daniel, Chris - Tracker Supp, Vasyl-Tracker Dev Team, Sean - Tracker, Andrew - Tracker Support, Tracker - Clarion Support, John - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software, Support Staff, moderators

Post Reply
fripco
User
Posts: 4
Joined: Mon Feb 26, 2007 8:58 pm

Pxc30Com Error

Post by fripco » Mon Feb 26, 2007 9:26 pm

We have the following code in a Powerbuilder program:

li_rtn = ConnectToNewObject("Pxc30Com.PXCControl")

The return value is -2 "Class name not found."

Any suggestions what might be causing this?

Thanks!

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Tue Feb 27, 2007 8:53 am

Hi,

Please can you advise what version of windows you are using and is it 32/64 bit - if Vista/XP please ?

Thanks
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

fripco
User
Posts: 4
Joined: Mon Feb 26, 2007 8:58 pm

Post by fripco » Tue Feb 27, 2007 3:08 pm

Our development environment is XP-Pro 32 bit, but the program can be deployed on Win98 and XP Home. We are working on, but very wary of Vista (put the install disk down, step away and no one will get hurt!)

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Tue Feb 27, 2007 4:23 pm

Hi,

It would appear there are issues with the COM control name - please modify to:

"pxc30COM.CPXCControl"

HTH
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

fripco
User
Posts: 4
Joined: Mon Feb 26, 2007 8:58 pm

Post by fripco » Tue Feb 27, 2007 4:36 pm

Thanks for the reply - I guess I wasn't too clear with my original post. The error shows up at a client site, not in our development environment. We have over 1500 sites running the software.

The client is running the program on XP Pro with SP2.

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Tue Feb 27, 2007 4:55 pm

Hi,

Have you ensured the COM object is registered correctly at this site as it would appear that it is not ?
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

fripco
User
Posts: 4
Joined: Mon Feb 26, 2007 8:58 pm

Post by fripco » Tue Feb 27, 2007 5:13 pm

You got it - we just tried registering that dll and it failed, so there's something blocking it. We'll troubleshoot it from there. Thanks so much for your help - much appreciated!

Alan.

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Tue Feb 27, 2007 5:20 pm

Pleasure and hope all goes well :-)
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

Post Reply