image watermarks in acrobat reader 7

This Forum is for the use of Software Developers requiring help and assistance for Tracker Software's PDF-XChange Printer Drivers SDK (only) - Please use the PDF-Tools SDK Forum for Library DLL assistance.

Moderators: Tracker Support, TrackerSupp-Daniel, Chris - Tracker Supp, Vasyl-Tracker Dev Team, Sean - Tracker, Andrew - Tracker Support, Tracker - Clarion Support, John - Tracker Supp, Tracker Supp-Stefan, Ivan - Tracker Software, Support Staff, moderators

Post Reply
ADeeg
User
Posts: 38
Joined: Tue Jan 04, 2005 1:30 pm
Location: Berlin

image watermarks in acrobat reader 7

Post by ADeeg » Tue May 16, 2006 9:59 pm

Hi Support,

I add images (bmp and jpg) as watermarks to existing PDF-files. If I open the new PDF in older Acrobat Readers (V 4.05) it looks fine but in newer Versions (V 7.07) I can't see any watermarks.

The PDF was created by your printer driver. I use the newest versions (3.50.0100) of the driver and the SDK.
I get the same result by using your Delphi Sample which was posted on the 3. January in this forum.

Is this a known bug or is the any workaround?

Many thanks!

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed May 17, 2006 9:09 am

It is not a known issue at all - please supply samples ('zipped') and we will be pleased to investigate.

Thanks
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

ADeeg
User
Posts: 38
Joined: Tue Jan 04, 2005 1:30 pm
Location: Berlin

Sample

Post by ADeeg » Wed May 17, 2006 10:37 am

OK, here are my sample files. As watermark I used the orig.gif from your TestFiles.
Attachments
myPDF.zip
Sample PDFs
(16.12 KiB) Downloaded 150 times

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed May 17, 2006 11:06 am

Hi,

Upon analysing the file - the images do appear to be there - but it would appear you have the Opacity (Opaque setting) set to '0' - increasing this should reveal your images as required.

Acrobat Reader 4.x reveals the images ok because it does not support this feature.

Opaque = 0 -- fully transparent
Opaque = 255 -- no transparency;

HTH
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

ADeeg
User
Posts: 38
Joined: Tue Jan 04, 2005 1:30 pm
Location: Berlin

Post by ADeeg » Wed May 17, 2006 12:06 pm

Hi,

That's it. Thanks a lot!

I wonder why you left the Opacity to zero in your sample application? I think it would make sense to set it to another value.

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed May 17, 2006 4:44 pm

Hi

Pleased all is well and I will indeed advise our examples writer of the suggestion - seems logical to me.

Thanks.
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

luctussier
User
Posts: 8
Joined: Fri Apr 21, 2006 8:20 am

images don't apear when printing

Post by luctussier » Wed May 24, 2006 1:34 pm

Hi. This forum has helped me avoid some frustrating moments.

Now I’m working on a program that adds some images (OMR) to existing pdf files. Every thing seems to work fine. I open the modified document with Adobe Reader and I can see the images where I put them. However coming out of the printer (HP 4000N), these images are gone. My images are monochrome bit-maps.

I’ve created a small program that duplicates the problem and I am sending some sample data. Please help me find out what I need to do to make the images show up when I print them.

Thanks for any help you can give.
Attachments
addWatermark.zip
sample project and data
(142.07 KiB) Downloaded 163 times

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed May 24, 2006 2:04 pm

Hi,

You are the victim of a bug in Adobe Reader/Physical print driver combination - when printing - it does not support correctly transparent 1 bit (monochrome) images.

the work around either :

1: Dont use transparency with mono images

or

2: Or use a Grayscale image/wth transparency in place of the above combination.

HTH
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

luctussier
User
Posts: 8
Joined: Fri Apr 21, 2006 8:20 am

Post by luctussier » Wed May 31, 2006 2:55 pm

Oh, things were going so well on the project that I forgot to thank you for the tip. I was able to turn off the transparency for my monochrome images with this:
Water.m_TransColor = 0x80000000;

and it all WORKS. thanks,
Jim

John - Tracker Supp
Site Admin
Posts: 8202
Joined: Tue Jun 29, 2004 10:34 am
Location: Vancouver Island - Canada
Contact:

Post by John - Tracker Supp » Wed May 31, 2006 3:15 pm

Excellent - thanks for letting us know and pleased all is well :)
If posting files to this forum - you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded - thank you.

Best regards
Tracker Support
http://www.tracker-software.com

Post Reply